<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML+RDFa 1.0//EN"
  "http://www.w3.org/MarkUp/DTD/xhtml-rdfa-1.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.ecsoft2.org/misc/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="Free Pascal Compiler.A free multiplatform 32-bit TP/BP/Delphi highly compatible Pascal compiler (OS/2, Linux, FreeBSD, GO32v2 and Win32 available)." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="http://www.ecsoft2.org/free-pascal" />
<link rel="shortlink" href="http://www.ecsoft2.org/node/246" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="http://www.ecsoft2.org/free-pascal" />
<meta name="twitter:title" content="Free Pascal" />
<meta name="twitter:description" content="Free Pascal Compiler.A free multiplatform 32-bit TP/BP/Delphi highly compatible Pascal compiler (OS/2, Linux, FreeBSD, GO32v2 and Win32 available)." />
<meta name="twitter:image" content="http://www.ecsoft2.org/sites/ecsoft2.org/files/screenshots/free_pascal.jpg" />
  <title>Free Pascal | eCSoft/2</title>
  <link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_vZ_wrMQ9Og-YPPxa1q4us3N7DsZMJa-14jShHgRoRNo.css" media="screen" />
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_Q7R7Blo9EYqLDI5rIlO_T3uTFBjIXjLpcqMHjTvVdmg.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_W7EVrtbe7IrtKJZSvIOc1-Y6uMbmnQv7CNgc2ZK4cUU.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_XRJTD7i4neGPMUsP6PFwCyS2pXLLWwSJRmbpOMtVhYQ.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
#sliding-popup.sliding-popup-bottom{background:#0779BF;}#sliding-popup .popup-content #popup-text h2,#sliding-popup .popup-content #popup-text p{color:#ffffff !important;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_y6G2-fLqoDcuB7VpTpyaPAypOfxKSb3qVKO7I9EdEug.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_QnDBmiJdH2cxV_bVbIOJbMX-fXv6ARF9uVJYsPTHfBM.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/sites/ecsoft2.org/files/css/css_2THG1eGiBIizsWFeexsNe1iDifJ00QRS9uSd03rY9co.css" media="print" />

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/themes/bartik/css/ie.css?ohx9rr" media="all" />
<![endif]-->

<!--[if IE 6]>
<link type="text/css" rel="stylesheet" href="http://www.ecsoft2.org/themes/bartik/css/ie6.css?ohx9rr" media="all" />
<![endif]-->
  <script type="text/javascript" src="http://www.ecsoft2.org/sites/ecsoft2.org/files/js/js_MpKfe1sTh5JIVGCZ17DsAuT1rqAC38MLLlkjqjQ1X_k.js"></script>
<script type="text/javascript" src="http://www.ecsoft2.org/sites/ecsoft2.org/files/js/js_RIb5otzjVwuT-shUgD58iS-_UZ8yu2llwervCKDln_Y.js"></script>
<script type="text/javascript" src="http://www.ecsoft2.org/sites/ecsoft2.org/files/js/js_4LekzLIdX1I-29GG_H4NCOWLZ5gAhlPTmJBjrss8JGs.js"></script>
<script type="text/javascript" src="http://www.ecsoft2.org/sites/ecsoft2.org/files/js/js_PC1y83kDeFaK0lESFLM14wHkbd4J9U2dX1zRKm0vcok.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-246 node-type-record i18n-en footer-columns" >
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page-wrapper"><div id="page">

  <div id="header" class="with-secondary-menu"><div class="section clearfix">

    
          <div id="name-and-slogan">

                              <div id="site-name">
              <strong>
                <a href="/" title="Home" rel="home"><span>eCSoft/2</span></a>
              </strong>
            </div>
                  
                  <div id="site-slogan">
            The Complete OS/2 Software Encyclopedia          </div>
        
      </div> <!-- /#name-and-slogan -->
    
      <div class="region region-header">
    <div id="block-search-form" class="block block-search">

    
  <div class="content">
    <form action="/free-pascal" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-Fnu3FI6NLgYET1aj1ILnXgd8yVlmEVRpBDaqk7gDBQc" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>
</div>
  </div>

          <div id="main-menu" class="navigation">
        <h2 class="element-invisible">Main menu</h2><ul id="main-menu-links" class="links clearfix"><li class="menu-218 first"><a href="/">Home</a></li>
<li class="menu-2059"><a href="/last30days" title="">Last 30 days</a></li>
<li class="menu-1808"><a href="/popular">Popular content</a></li>
<li class="menu-762 last"><a href="/glossary" title="">Glossary</a></li>
</ul>      </div> <!-- /#main-menu -->
    
          <div id="secondary-menu" class="navigation">
        <h2 class="element-invisible">Secondary menu</h2><ul id="secondary-menu-links" class="links inline clearfix"><li class="menu-538 first last"><a href="/user/login" title="">Login</a></li>
</ul>      </div> <!-- /#secondary-menu -->
    
  </div></div> <!-- /.section, /#header -->

  
  
  <div id="main-wrapper" class="clearfix"><div id="main" class="clearfix">

<!--
          <div id="breadcrumb"><h2 class="element-invisible">You are here</h2><div class="breadcrumb"><a href="/">Home</a></div></div>
    -->
    
          <div id="sidebar-first" class="column sidebar"><div class="section">
          <div class="region region-sidebar-first">
    <div id="block-nice-menus-1" class="block block-nice-menus">

    
  <div class="content">
    <ul class="nice-menu nice-menu-right nice-menu-main-menu" id="nice-menu-1"><li class="menu-3816 menu-path-applications first odd "><a href="/applications" title="">Applications</a></li>
<li class="menu-3820 menu-path-development  even "><a href="/development">Development</a></li>
<li class="menu-3821 menu-path-system  odd "><a href="/system">System</a></li>
<li class="menu-3890 menu-path-utilities  even "><a href="/utilities">Utilities</a></li>
<li class="menu-3444 menu-path-documentation  odd "><a href="/documentation" title="">Documentation</a></li>
<li class="menu-3441 menuparent  menu-path-node-1625  even "><a href="/magazine">Magazines</a><ul><li class="menu-3447 menu-path-magazine-edm2-issues first odd "><a href="/magazine/edm2-issues">EDM/2</a></li>
<li class="menu-3450 menu-path-magazine-mcmicrocomputer-issues  even "><a href="/magazine/mcmicrocomputer-issues">MC microcomputer</a></li>
<li class="menu-3445 menu-path-magazine-os2-ezine-issues  odd "><a href="/magazine/os2-ezine-issues">OS/2 e-Zine</a></li>
<li class="menu-3446 menu-path-magazine-os2ecs-ezine-issues  even "><a href="/magazine/os2ecs-ezine-issues">OS2eCS e-Zine</a></li>
<li class="menu-3442 menu-path-magazine-voice-issues  odd "><a href="/magazine/voice-issues" title="">Voice Newsletter</a></li>
<li class="menu-4141 menu-path-node-1810  even last"><a href="/magazine/1996-01">Just WARP!</a></li>
</ul></li>
<li class="menu-1641 menu-path-how-to  odd last"><a href="/how-to" title="">How to</a></li>
</ul>
  </div>
</div>
<div id="block-locale-language" class="block block-locale">

    
  <div class="content">
    <ul class="language-switcher-locale-url"><li class="en first active"><a href="/free-pascal" class="language-link active" xml:lang="en"><img class="language-icon" src="http://www.ecsoft2.org/sites/all/modules/languageicons/flags/en.png" width="16" height="12" alt="English" title="English" /> English</a></li>
<li class="it last"><a href="/it/free-pascal" class="language-link" xml:lang="it"><img class="language-icon" src="http://www.ecsoft2.org/sites/all/modules/languageicons/flags/it.png" width="16" height="12" alt="Italiano" title="Italiano" /> Italiano</a></li>
</ul>  </div>
</div>
<div id="block-comment-recent" class="block block-comment">

    <h2>Recent comments</h2>
  
  <div class="content">
    <div class="item-list"><ul><li class="first"><a href="/comment/263#comment-263">Thanks I enjoy playing this</a>&nbsp;<span>3 weeks 4 days ago</span></li>
<li><a href="/comment/262#comment-262">ZIP versions are here</a>&nbsp;<span>1 month 1 day ago</span></li>
<li><a href="/comment/261#comment-261">The only zip package I see</a>&nbsp;<span>1 month 1 day ago</span></li>
<li><a href="/comment/260#comment-260">Many thanks Gianfilippo! I</a>&nbsp;<span>3 months 2 weeks ago</span></li>
<li class="last"><a href="/comment/259#comment-259">Ok, just done also the OS/2</a>&nbsp;<span>3 months 3 weeks ago</span></li>
</ul></div>  </div>
</div>
<div id="block-block-10" class="block block-block">

    
  <div class="content">
    <p><a class="twitter-follow-button" href="https://twitter.com/eCSoft2" data-show-count="false" data-size="large">Follow @eCSoft2</a></p>
<script type="text/javascript">
<!--//--><![CDATA[// ><!--
// <![CDATA[
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');
// ]]]]><![CDATA[>
//--><!]]>
</script>  </div>
</div>
  </div>
      </div></div> <!-- /.section, /#sidebar-first -->
    
    <div id="content" class="column"><div class="section">
            <a id="main-content"></a>
                    <h1 class="title" id="page-title">
          Free Pascal        </h1>
                          <div class="tabs">
                  </div>
                          <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-246" class="node node-record node-full clearfix">

      
  
  <div class="content clearfix">
    <div class="field field-name-field-ver field-type-text field-label-inline clearfix"><div class="field-label">Version:&nbsp;</div><div class="field-items"><div class="field-item even">3.0.2</div></div></div><div class="field field-name-field-release-date field-type-datetime field-label-inline clearfix"><div class="field-label">Release date:&nbsp;</div><div class="field-items"><div class="field-item even"><span class="date-display-single">Friday, 17 February, 2017</span></div></div></div><div class="field field-name-field-homepage field-type-link-field field-label-inline clearfix"><div class="field-label">Home:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="http://www.freepascal.org/">http://www.freepascal.org/</a></div></div></div><div class="field field-name-field-author field-type-taxonomy-term-reference field-label-inline clearfix"><h3 class="field-label">Authors/Port authors: </h3><ul class="links inline"><li class="taxonomy-term-reference-0"><a href="/authors/free-pascal-compiler-team">Free Pascal Compiler Team</a></li></ul></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"><p>Free Pascal Compiler.</p>
<p>A free multiplatform 32-bit TP/BP/Delphi highly compatible Pascal compiler (OS/2, Linux, FreeBSD, GO32v2 and Win32 available).</p>
</div></div></div><div class="field field-name-field-categories field-type-taxonomy-term-reference field-label-inline clearfix"><h3 class="field-label">Categories: </h3><ul class="links inline"><li class="taxonomy-term-reference-0"><a href="/development-pascal">Development: Pascal</a></li></ul></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-inline clearfix"><h3 class="field-label">License: </h3><ul class="links inline"><li class="taxonomy-term-reference-0">GPL</li></ul></div><div class="field field-name-field-interface field-type-taxonomy-term-reference field-label-inline clearfix"><h3 class="field-label">Interface: </h3><ul class="links inline"><li class="taxonomy-term-reference-0">VIO</li></ul></div>  </div>

      <div class="link-wrapper">
      <ul class="links inline"><li class="it first last"><a href="/it/free-pascal" class="language-link" xml:lang="it"><img class="language-icon" src="http://www.ecsoft2.org/sites/all/modules/languageicons/flags/it.png" width="16" height="12" alt="Italiano" title="Italiano" /> Italiano</a></li>
</ul>    </div>
  
  
</div>
  </div>
</div>
<div id="block-views-record-page-slideshow-block" class="block block-views">

    
  <div class="content">
    <div class="view view-record-page-slideshow view-id-record_page_slideshow view-display-id-block view-dom-id-d6f5c2a201a75dfc78551de00c1087db">
        
  
  
      <div class="view-content">
      
  <div class="skin-default">
    
    <div id="views_slideshow_cycle_main_record_page_slideshow-block" class="views_slideshow_cycle_main views_slideshow_main"><div id="views_slideshow_cycle_teaser_section_record_page_slideshow-block" class="views-slideshow-cycle-main-frame views_slideshow_cycle_teaser_section">
  <div id="views_slideshow_cycle_div_record_page_slideshow-block_0" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-1 views-row-odd">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-0 views-row-odd views-row-first center">
    
  <div class="views-field views-field-field-sshot">        <div class="field-content"><a href="http://www.ecsoft2.org/sites/ecsoft2.org/files/styles/vga/public/screenshots/free_pascal.jpg?itok=y49ModKP" title="Free Pascal" class="colorbox" data-colorbox-gallery="gallery-node-246-TtQiZuC-0bw"><img src="http://www.ecsoft2.org/sites/ecsoft2.org/files/styles/qvga/public/screenshots/free_pascal.jpg?itok=hsq0zjop" width="212" height="100" alt="" title="" /></a></div>  </div></div>
</div>
<div id="views_slideshow_cycle_div_record_page_slideshow-block_1" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-2 views_slideshow_cycle_hidden views-row-even">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-1 views-row-even views-row-last center">
    
  <div class="views-field views-field-field-sshot">        <div class="field-content"><a href="http://www.ecsoft2.org/sites/ecsoft2.org/files/styles/vga/public/screenshots/fpc.png?itok=lGs1pGjg" title="Free Pascal" class="colorbox" data-colorbox-gallery="gallery-node-246-TtQiZuC-0bw"><img src="http://www.ecsoft2.org/sites/ecsoft2.org/files/styles/qvga/public/screenshots/fpc.png?itok=Vmzwoth3" width="320" height="215" alt="" title="" /></a></div>  </div></div>
</div>
</div>
</div>
      </div>
    </div>
  
  
  
  
  
  
</div>  </div>
</div>
<div id="block-views-installation-new-block" class="block block-views">

    <h2>Installation</h2>
  
  <div class="content">
    <div class="view view-installation-new view-id-installation_new view-display-id-block view-dom-id-a4100a0ccd4293d5dbc52398c1cae5fe">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-pb-installation-instructio">        <div class="field-content"><div class="entity entity-paragraphs-item paragraphs-item-pb-installation-zip">
  <div class="content">
    <div class="field field-name-field-pb-inst-instr field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p style="text-align: justify;">Program is distributed as <a href="/info-zip-unzip" title="Info-Zip Unzip">ZIP</a> package: download to temporary directory and unpack to destination folder. See below for download link(s).</p>
</div></div></div>  </div>
</div>
</div>  </div>  </div>
    </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-installation-new view-id-installation_new view-display-id-attachment_1">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_2">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_3">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_4">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_5">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_6">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_7">
        
  
  
  
  
  
  
  
  
</div><div class="view view-installation-new view-id-installation_new view-display-id-attachment_8">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>
</div>
<div id="block-views-record-page-block" class="block block-views">

    <h2>Download</h2>
  
  <div class="content">
    <div class="view view-record-page view-id-record_page view-display-id-block view-dom-id-682b0bed1774d65d65eff00f77ff7dc5">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 3.0.2 (<span class="date-display-single">17/02/2017</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/3.0.2/i386-os2/os2302full.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/3.0.2/i386-os2/os2302full.zip</a></div>  </div>  
          
<fieldset class="what039s-new views-fieldset collapsible collapsed" data-module="views_fieldsets">

  <legend>
    <span class="fieldset-legend">What&#039;s new</span>
  </legend>

  <div class="fieldset-wrapper">
          <div class="views-field views-field-field-download-whats-new"><div class="field-content"><div class="preformatted">                            Free Pascal Compiler

                                Version 3.0.2

******************************************************************************
                              What&#039;s New in 3.0.2
******************************************************************************

Free Pascal 3.0.2 is a point release of the 3.0.x fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_3.0.2 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Rtl:
  * TRect, TPoint and similar types are now type compatible between
    Types and Windows unit, and are now advanced records. 

Packages:
  * googleapi and fcl-pdf packages.
  * fcl-db and web packages synchronized 
  * unicode tables updated.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

                            Free Pascal Compiler

                                Version 3.0.0

******************************************************************************
                              What&#039;s New in 3.0.0
******************************************************************************

Free Pascal 3.0.0 is a new major release providing support for new
architectures and targets and also many new features and compatibility fixes.

Please also see http://wiki.freepascal.org/User_Changes_3.0.0 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * New processor architecture: MIPS (big and little endian variants)
  * New processor architecture: i8086 (primarily focusing legacy MS-DOS)
  * New &quot;processor&quot; architecture: JVM
  * Revived support for Motorola 68k processors (previously available
    in 1.0.x series)
  * Considerably extended supported range of ARM processor variants
  * New platform: AIX/PowerPC
  * New platform: AIX/PowerPC64
  * New platform: Android/ARM
  * New platform: Android/i386
  * New platform: Android/JVM
  * New platform: Android/MIPSEL
  * New platform: AROS/i386
  * New platform: DragonFly/x86_64
  * New platform: Java/JVM
  * New platform: Linux/MIPS
  * New platform: Linux/MIPSEL
  * New platform: msdos/i8086

Compiler:
  * New support for codepage-aware strings (bringing improved compatibility
    to recent Delphi versions)
  * Support for processor sub-architectures (mostly for ARM variants)
  * Support for multiple memory models (i8086 - including memory models
    not supported with the last TP/BP compilers)

RTL:
  * Partial support for codepage-aware strings and Unicode in the RTL
    including transparent character set conversion
  * OS/2 RTL finally provides full support for UnicodeString handling
    when running under OS/2 versions including such support (OS/2 Warp 4
    and up)
  * Direct support for certain OS/2 API functions only available in later
    OS/2 versions while allowing the created binaries to run also on older
    versions

Packages:
  * Big improvements of fpmake (fpmkunit) - all packages and utilities
    (actually everything except the compiler and RTL) are now built using
    fpmake which somewhat decreases dependency on external utilities.
  * New packages rtl-* containing units previously included in RTL; this
    allowed streamlining the RTL and thus speeding up RTL building.
  * New package fpwidestring - native implementation of Unicode string
    handling routines. This allows full support of UnicodeString also
    on targets not supporting Unicode natively or possibly on targets
    requiring linking to libc for such support.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.4
******************************************************************************

Free Pascal 2.6.4 is a point release from the 2.6.0 fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_2.6.4 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:

Packages:
  * Lots and lots fixes and improvements for fcl-db
  * Web and json packages synchronized.
  * Improvements to the chmcmd compiler.
  * Several fixes for winunits (and winceunits)

Platforms:


See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.2
******************************************************************************

Free Pascal 2.6.2 is a point release from the 2.6.0 fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_2.6.2 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:
  * Improvements and fixes for the ARM architecture

Packages:
  * New package fpindexer (indexing engine)
  * Support for observer pattern added to fcl-base (and base classes in RTL)
  * Lots and lots fixes and improvements for fcl-db
        * Support for JSON dataset added among others
  * Fixes and improvements for fcl-passrc (and fpdoc)
  * Updates for PTCPas and gtk2
  * Fpmkunit improvements (better support for future switch to fpmake)
  * Several fixes for x11
  * Several fixes for winunits (and winceunits)

Platforms:
  * Improvements to the NativeNT target (newly introduced as alpha in 2.6.0)
  * Many fixes for OpenBSD and NetBSD (considered in beta state now)
  * Internal ELF writer supported for more BSD targets
  * Fixes and improvements for gba and nds

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.0
******************************************************************************

Free Pascal 2.6.0 is a new major version of the Free Pascal compiler.

Please also see http://wiki.freepascal.org/User_Changes_2.6.0 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * iPhoneSimulator target

Compiler:
  * Many new language features:
     * Objective-Pascal dialect, supported on all Mac OS X and iOS targets
     * constref parameter modifier for &quot;const by reference&quot;
     * Pascal boolean types with multiple sizes (boolean16/32/64)
     * ISO 7185 language mode (except for I/O). Features amongst others:
        * nested procedure variables
        * non-local goto&#039;s
     * Mac Pascal mode improvements
        * nested procedure variables
        * univ modifier
     * Intrinsics
        * sar (shift arithmetic right)
        * bsf/bsr (bitscan forward/reverse)
     * Delphi compatibility mode improvements
        * Nested types, class variables and class local constants
        * Advanced records syntax (no constructors yet)
        * (for..in) Enumerators in records
        * Class and record helpers
        * Generic records, arrays and procedural types
        * Delphi-compatibility of generics improved
        * Scoped enumerations
        * Custom messages for &quot;deprecated&quot; directive
        * Ability to use &quot;&amp;&quot; for escaping keywords
  * New ARM code generator features
     * ARM VFPv2 and VFPv3 floating point unit support
     * Thumb-2 support

Packages:
  * Many improvements to the rtl
  * Many improvements to the database units (fcl-db)
  * Objective-Pascal interfaces to Foundation, AppKit, CoreData and WebCore
  * OpenGL headers updated to OpenGL 4.0
  
Details about these new features can be found at
http://wiki.freepascal.org/FPC_New_Features_2.6.0

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs that have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.4.4
******************************************************************************

Free Pascal 2.4.4 contains most library fixes from early June 2010 till March
2011. There are also some compiler fixes, mostly relating to 64-bit.

Please also see http://wiki.freepascal.org/User_Changes_2.4.4 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Packages:
  * Many improvements to the XML units
  * Many improvements to the database units. 
        * Specially sqlite got quite some fixes.
  * Many improvements to the chm units. 
        * Including a commandline CHM compiler 
  * Many improvements to fppkg and fpmake for another round of testing.

Platforms:
  * Fixes for multi-threading support in OS/2 RTL.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.4.2
******************************************************************************

Free Pascal 2.4.2 contains many fixes and a few new features. Most bugfixes
in the RTL and packages before June 2010 have been merged.

Please also see http://wiki.freepascal.org/User_Changes_2.4.2 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:
  * Support D2006+ FOR..IN, with some FPC specific enhancements. Refer to
     http://wiki.freepascal.org/for-in_loop for more information
  * Support for sealed and abstract classes.

Packages:
  * The existing Mac OS X Universal Interfaces units have been synchronised
    with the Mac OS X 10.6 SDK. Several new units have also been added, and
    where indicated in the Mac OS X 10.6 SDK they have also been enabled for
    iPhoneOS/iOS.
  * Many improvements to the XML units
  * Many improvements to the database units
  * Many improvemnets to the chm units

Platforms:
  * Long term bug in OS/2 implementation of unit Video finally fixed which
    among others allows inclusion of the text-mode IDE (without debugger)
    for this platform as part of the distribution again.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.4.0
******************************************************************************

Free Pascal 2.4.0 contains many fixes and new features. While we did not
manage to incorporate all planned additions, we believe this release offers a
nice collection of new functionality and bug fixes.


Please also see http://wiki.freepascal.org/User_Changes_2.4.0 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * New platform: Mac OS X/PowerPC64
  * New platform: Mac OS X/x86_64
  * New platform: Mac OS X/ARM (iPhone)

Compiler:
  * Support for Delphi-style resource handling
  * Whole-program optimization infrastructure, which initially supports
    program devirtualization and unused virtual method removal
  * Much faster compilation of units containing many type-sections
  * The ability to suppress individual hints/warnings/notes
  * Several improvements to the DWARF debug information generation
  * Fixes to the generics support
  * Fixes to the interface delegation (implements) support
  * Improved cpu register allocation
  * Improved ARM/EABI support
  
RTL:
  * Linearly scaling multi-threaded memory manager
  * Support for (advisory) file locking on Unix-based platforms
    when using the SysUtils file creation/opening routines
  * Support for ANSI ISO Extended Pascal ReadStr/WriteStr
  * A UnicodeString type that, while not yet equivalent to Delphi 2009&#039;s
    UnicodeString type, offers reference counted UnicodeString support on
    the Windows, Linux, Mac OS X, FreeBSD and Beos/Haiku platforms.

Packages:
  * Many improvements to the XML units
  * Many improvements to the database units
  * Updated the common Mac OS X Pascal interfaces to r241, including
    an updated header translation of the CFNetwork framework
  * The zipper unit now works correctly on big endian platforms

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.4
******************************************************************************

Free Pascal 2.2.4 contains many bug fixes and some new features. The 
main purpose of this release is to fix problems reported with FPC 2.2.2.

Please also see http://wiki.freepascal.org/User_Changes_2.2.4 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

All:
  * Experimental packages-installation tool

Packages:
  * Added support for TIFF reading/writing in fcl-image
  * Improvements and fixes in CHM support
  * Fixed linking the gtk2-package with gtk versions above 2.13.4

IDE:
  * Added support for CHM help files

Documentation

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.2
******************************************************************************

Free Pascal 2.2.2 contains many bug fixes and some new features. The 
main purpose of this release is to fix problems reported with FPC 2.2.0,
and to remove all potentially tainted code from our source code base.

Please also see http://wiki.freepascal.org/User_Changes_2.2.2 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

All:
  *  All code potentially infringing on CodeGear copyrighted code has been
     reimplemented using a cleanroom approach.

Platforms:
  * Incompatibilities with Mac OS X 10.5&#039;s new default linker have been
    resolved.

Compiler:
  * PIC support for Mac OS X (on by default, disable with -Cg-)
  * several bugs in the experimental generics support have been fixed,
    but this feature is still in beta
  * initialisation and finalisation of shared libraries has been fixed
    for all Darwin platforms, and for Linux/i386
  * support for {$packset x} directive to enable set packing
    (use {$packset 1} for Delphi-compatible sets, but note that the
     format is different on little and big endian platforms)

RTL:
  * thread resource leaking under unix has been fixed
  * the widestring manager for unix has been completed
  * several floating point to string conversion errors have been fixed
  * significantly improved variant support
  * implementation of RTL exception handler for OS/2 allowing proper
    translation of some runtime errors
  * various fixes for GO32v2 improving useability of this target
  * OS/2 RTL enhanced to allow seamless working with large files (64-bit
    file system API calls) where available (WSeB/MCP/eCS/Warp 4 with FP15)

Packages:
  * the Windows API interface units have been significantly updated
  * Apple universal interfaces updated to r234 of the common FPC/GPC/MW
    interfaces
  * New TRegexEngine class to parse regular expressions

Documentation
  *  Documentation was updated completely to conform to the actual
     state of the compiler and RTL.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.0
******************************************************************************

Free Pascal 2.2.0 contains a lot of bug fixes and new features. The work on
Free Pascal 2.2.0 started halfway during the year 2005. A lot has been improved
since then.

Please also see http://wiki.freepascal.org/User_Changes_2.2.0 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Platforms:
  * New platform: Win64. FPC is the first open source compiler for 64-bit
     Windows operating systems.
  * New processor architecture: 64-bit PowerPC
    * PowerPC/64 support for Linux
  * Mac OS X on Intel (i386) is now supported
  * New platform: Windows CE (Windows Mobile)
  * New platform: Nintendo Game Boy Advance
  * New platform: Nintendo DS
  * Native support for ARM-platform
  * GO32V2 DOS platform got a long needed update

Compiler:
  * Internal linker for win32, win64 and wince, resulting in smaller
    executables, less memory used during compilation, and faster compile
    times for programs using large frameworks like for example the Lazarus
    Component Library.
  * Generics (experimental)
  * Bit packed arrays and records
  * Resourcestrings can now be smartlinked, resulting in smaller executables
  * Multiple resource files support
  * pointer[low..high] syntax to pass C-style pointer arrays to procedures
    using open arrays
  * Interface delegation
  * Proper safecall implementation
  * Wide strings are COM/OLE compatible on Windows
  * Added several speed optimisations, for example:
    * Compiler can omit stack frames (x86 and ARM)
    * Compiler can store records in registers
    * Tail recursion expansion
    * Register renaming optimizations
  * Improved optimizer for ARM CPU
  * Compiler can initialise local variables, function results, and &quot;out&quot;
    parameters with several values (command line parameters -gt till -gtttt)
    to help find uses of uninitialised variables
  * Compiler can now properly deal with paths &gt; 255 characters in all cases
  * Dwarf debug format support
  * Reduced memory usage during compilation
  * Lot of small bugs and compatibility fixes

RTL:
  * Heap uses less memory
  * Improved variants support
  * Improved currency support
  * Exception handling can be used without SysUtils unit
  * Lot of small bug and compatibility fixes

FCL:
  * Improved database support
  * The obsolete sqlitedataset, interbase, fpodbc, ddg, mysqldb3 and mysqldb4
    units are removed
  * Lot of small bugs and compatibility fixes

Packages:
  * Added a new fppkg package manager
  * Improved database support
  * Added Delphi compatible RichEdit unit
  * Apple universal interfaces updated to r204 of the common FPC/GPC/MW
    interfaces
  * Lot of small bugs and compatibility fixes

Free Vision:
  * Now uses resourcestrings

IDE:
  * Evaluate window
  * Improved HTML rendering
  * Improved xterm support
  * Small bug fixes

Misc:
  * Improved documentation
  * Better cross compilation support

For a detailed list of reported bugs that are fixed in this release see the
bugtracker report at http://www.freepascal.org/mantis/changelog_page.php


******************************************************************************
                              What&#039;s New in 2.0.4
******************************************************************************

More than 1000 changes have been made to 2.0.4 since 2.0.2. As this is a bug
fix release, most are fixes for some issues, but new features and performance
enhancements have been added as well.

Compiler:
  * Lot of small bugs and compatibility fixes
  * Updated several translations
  * Improved code generation
  * Improved and fixed PIC code generation
  * Improved register allocation
  * Improved ansistring string code generation
  * Several alignment values increased so the requirements of modern processors
    are met better
  * WINDOWS defined on all windows platforms (Win32, Win64, WinCE)
  * Parameter order for methods with structured results changed
    (result pointer&lt;-&gt;self swapped), please check such methods if they are
    implemented in assembler
  * i386 compiler no longer needs environment variables set when installed on
    an x86_64 Linux distribution

RTL:
  * Lot of small bug and compatibility fixes
  * 64 bit file pointer support on most targets
  * Faster integer to string conversion
  * Endian conversion routines added
  * Improved heap manager
  * Improved ansistring routines
  * PowerPC: Power3/4/5/PPC970 compatibility

FCL:
  * Lot of small bugs and compatibility fixes
  * Improved database support
  * The interbase, fpodbc, ddg, mysqldb3 and mysqldb4 units
    are obsolete and replaced by the sqldb components
  * Oracle support added

Packages:
  * Lot of small bugs and compatibility fixes
  * Improved database support
  * Apple universal interfaces added

Free Vision:
  * New outline unit
  * Small bug fixes
  * Unix: much improved video and keyboard handling
  * Unix: Free Vision applications no longer need to link to libc
  * Linux: grab_vcsa utility to ensure vcsa access

IDE:
  * Small bug fixes
  * Redesigned directories window
  * Reorganised compiler options window
  * Option to use Ctrl+X,C,V for cut/copy/paste

Misc:
  * Improved documentation
  * Better cross compilation support

******************************************************************************
                              What&#039;s New in 2.0.2
******************************************************************************
This is a bug fix release, so don&#039;t expect a big new feature list here. Most
of the almost 700 changes made to 2.0.2 since 2.0.0 are fixes for some issues.

Compiler:
  * Lot of small bugs and compatibility fixes
  * Improved SSE support
  * Improved inlining
  * Enhanced variant support
  * Embedded resource support for targets using elf32 executable format
  + Type checking of compile time expressions
  + Mode MacPas: Support for Mac style objects
  + Mode MacPas: Compile time variables can be given on command line

RTL:
  * Lot of small bugs and compatibility fixes
  * Enhanced variant support
  * Embedded resource support for targets using elf32 executable format

FCL:
  * Lot of small bugs and compatibility fixes
  * Improved SqlDB package

Packages:
  * Lot of small bugs and compatibility fixes
  * Improved data base support

IDE:
  * Small bug fixes

Misc:
  * Improved docs
  * Bug fixes for FreeVision

******************************************************************************
                              What&#039;s New in 2.0.0
******************************************************************************
Compiler:
  + properties in objects are now allowed
  + use of cmov when at least -Cppentium2 is supplied (i386+ only)
  + .p is a searched source extension in macpas mode now
  * Improved MacPas mode
  * Improved variant support
  * Updated language files
  * Improved warnings regarding uninitialised variables
  * Lot of small bugs and compatibility fixes

RTL:
  * Several widestring and unicode fixes
  * Heavily improved variant support
  * Improved threading support
  * Improved 64 bit compatibility
  * Lot of small bugs and compatibility fixes

FCL:
  * Improved data base support
  * Lot of small bugs and compatibility fixes

Packages:
  + Jedi windows api is part of the packages now
  + Windows specific units of the rtl have been moved to packages/base/winunits
  + XFree header conversions to X package added
  * Endian and 64 bit fixes
  * Lot of small bugs and compatibility fixes

IDE:
  * Small bug fixes

Misc:
  * Improved docs
  * Bug fixes for FreeVision


******************************************************************************
                      What&#039;s New in 1.9.8 aka 2.0.0-Rc2
******************************************************************************


Compiler:
  + arm-linux cross compiler for i386-linux
  + SysV style syscalls added for MorphOS
  + Exportable macros for mode MacPas
  + Support procvar declaration in parameters for mode MacPas
  + Give warning if code is never executed in while/if statements
  + Directive {$COPERATORS ON} added, synomym for -Sc
  + Check for uninitialzed from and to values in for-loop statement
  + -Fa&lt;unit&gt; option added to load units in a program before the uses statement
    is parsed
  + -vz for output to stderr
  * Better support for unique types
  * AfterConstruction/BeforeDestruction behaviour is now compatible with Delphi
  * Better support for Widestring
  * Removed {$THREADING ON} directive, threading support is always available
  * Improved code generation on Sparc
  * Lot of small bugs and compatibility fixes
  + On target Mac OS, resource files is supported

RTL:
  + arm Linux support
  * Basic threading support moved to the system unit
  * Operator ** moved to math unit; system.power removed
  * Improved variant support
  * Lot of small bugs and compatibility fixes
  + The unit MacOS (api to Mac OS) for target MacOS

FCL:
  + Support for Interbase/Firebird, PostgreSQL and MySQL 4.0 under windows
  * Database drivers are now dynamically loaded
  * The TSQLQuery is now fully editable using cached updates
  * Lot of small bugs and compatibility fixes

Packages:
  + gtk2 interface units
  * 64 bit compatibility fixes
  * Lot of small bugs and compatibility fixes

IDE:
  + vector unit window
  * x86-64 asssembler debugging support improved
  * Sparc asssembler debugging support improved
  * Some bug fixes

Misc:
  + txt output to fpdoc added
  * some fpdoc bugs fixes
  + demo for macos


******************************************************************************
                      What&#039;s New in 1.9.6 aka 2.0.0-Rc1
******************************************************************************

Compiler:
  + x86_64/amd64 (Linux) compiler
  + Sparc (Linux) compiler
  + PowerPC MorphOS support
  + Mac OS (classic) compiler (for MPW)
  + Netware Libc support (-Tnetwlibc)
  + Register variable support (-Or) for all targets
  + MacPas compiler mode (-Mmacpas)
  * Better inlining support
  * For loop variable assignment is not allowed anymore
  * $fpctarget expands to &lt;cpu&gt;-&lt;os&gt; (except for 8.3 limited targets),
    old $target removed
  * Implicit loading of Variants unit
  * Lots of bug fixes

RTL:
  + x86_64/amd64 Linux support
  + Sparc Linux support
  + PowerPC MorphOS support
  + Mac OS (classic) support (except Sysutils and its dependants)
  + Netware Libc support
  + New heap manager that releases memory back to the OS
  + TThread.Synchronize support
  + utf8bidi unit
  + GetHeapStatus added
  + GetProcessID added
  + SysUtils.GetEnvironmentVariableCount and SysUtils.GetEnvironmentString added
  * gpm unit does not need libgpm anymore
  + Further additions for improved Delphi compatibility
  + System.GetProcessID and System.GetThreadID added
  + Dos.GetMsCount added
  + Support for changing console resolution in Video for Win32
  + Support for using high memory (&gt; 512 MB) under OS/2 (where available)
  - Removed MaxAvail, MemAvail, HeapSize due to their unreliability
    (bogus/misleading return values) in multitasking environment with swapping

FCL:
  + RTTIUtils unit added
  + fpcunit test-framework added
  * Lots of dbf and other db fixes

FV:
  * Updated to fvision implementation, first official release

IDE:
  * Lots of improvements and stability fixes
  * Support latest gdb 6.2.x and 6.3.x releases

Docs:
  + Lots of updates
  + Easier to navigate html documentation
  * fpDoc is used to generate all unit documentation

Misc:
  * Makefiles create units in a separate directory units/cpu-os/
  * More cross compilation improvements


******************************************************************************
                      What&#039;s New in 1.9.4 aka 2.0.0-Beta3
******************************************************************************

Compiler:
  + ARM (Linux) compiler
  + PowerPC Darwin (Mac OS X) support
  + reintroduce keyword support
  + added prefetch(const mem) support
  + MacPas compile mode
  + -gv to generate an executable that can be run under Valgrind &gt;= 2.1
  * register allocator fixes and tweaks
  * better support for preprocessor $IF expressions
  * better overloaded operator support
  * Win32 DLL export table fixes
  * stabs (debuginfo) generation cleanups
  * enum names in RTTI are now in their original case
  * record alignment fixes
  * lots of bug fixes

RTL:
  + ARM Linux support
  + Powerpc Darwin support
  + Sysutils.RaiseLastOSError added
  + Sysutils.GetLastOSError added
  + Classes.TOwnedCollection added
  + Sysutils.FileIsReadOnly added
  + support of widestring and currency in the typinfo unit
  * Better support for Libc based RTL (FPC_USE_LIBC)
  * 64bit cleanup for future x86_64 port
  * ExecuteProcess fixes
  * Linux use getdents syscall instead of deprecated readdir
  * bug fixes

FCL:
  + SDF DB backend
  + TGA support in fpImage
  + support of widestring and currency type in stream related classes
  * Lot of fixes to fpImage classes

Misc:
  * better cross development support
  * Documentation updates
  * Testsuite updates to store testrun results in a database
  * Testsuite updates for cross platform testing, with remote rsh/ssh support


******************************************************************************
                      What&#039;s New in 1.9.2 aka 2.0.0-Beta2
******************************************************************************

Compiler:
  + PowerPC compiler
  + sse/sse2 code generation support
  + &quot;global&quot; property support
  * improved inlining support
  * optimizer enabled again
  * uses register calling conventions by default
  * $fputype directive
  + properties of type single can have default values
  + support of $IF DECLARED()
  + support of DQWORD in inline intel assembler code
  * lots of bug fixes

RTL:
  * more improvements for unix runtime library
  * using FPC_USE_LIBC allows to compile an rtl which uses libc instead of
    syscalls
  + System.Initialize
  + Sysutils.ExecuteProcess
  + System.WideStringManager
  + System.PtrInt and System.PtrUInt
  * ipv6 support
  * lots of bug fixes

FCL:
  + sqlite support
  * bug fixes

Misc:
  * improved docs

******************************************************************************
                      What&#039;s New in 1.9.0 aka 2.0.0-Beta1
******************************************************************************

Compiler:
  + dynamic arrays
  + interfaces
  + variants
  + full widestring support
  + default parameters
  + cross name scope overloading
  + support for the PowerPC, Sparc and ARM processor, installation packages
    will follow within the next weeks
  + new and more sophisticated register allocator
  + inlining across units
  + register calling conventions
  + SSE and SSE2 support for inline assembler
  + PIC code generation
  + new language mode: &quot;Mac Pascal&quot;
  + full boolean evaluation is now also available
  + threadvar support, enabled by using {$threading on}
  * support of int64 integer constants
  * improved Delphi compatibility in -Sd mode
  * a lot of bug fixes
  * large parts of the compiler are rewritten to create a more stable,
    portable and maintainable compiler

RTL:
  + multithreading support
  * completely rewritten unix runtime library
  * improved Delphi compatiblity
  * significantly improved speed of exception related code
  * prepared for big endian and 64 Bit CPUs
  * a lot of bug fixes

FCL:
  + tdataset support
  + html generator
  + 64 Bit file handling
  * a lot of bug fixes

Docs:
  * adapted to reflect new language features

IDE:
  * a lot of bug fixes

Misc:
  * improved cross compilation</div></div></div>      </div>

</fieldset>

    </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 3.0.2, docs (<span class="date-display-single">17/02/2017</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/3.0.2/i386-os2/separate/docs/doc-pdf.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/3.0.2/i386-os2/separate/docs/doc-pdf.zip</a></div>  </div>  
          
<fieldset class="what039s-new views-fieldset collapsible collapsed" data-module="views_fieldsets">

  <legend>
    <span class="fieldset-legend">What&#039;s new</span>
  </legend>

  <div class="fieldset-wrapper">
          <div class="views-field views-field-field-download-whats-new"><div class="field-content"><div class="preformatted">                            Free Pascal Compiler

                                Version 3.0.2

******************************************************************************
                              What&#039;s New in 3.0.2
******************************************************************************

Free Pascal 3.0.2 is a point release of the 3.0.x fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_3.0.2 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Rtl:
  * TRect, TPoint and similar types are now type compatible between
    Types and Windows unit, and are now advanced records. 

Packages:
  * googleapi and fcl-pdf packages.
  * fcl-db and web packages synchronized 
  * unicode tables updated.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

                            Free Pascal Compiler

                                Version 3.0.0

******************************************************************************
                              What&#039;s New in 3.0.0
******************************************************************************

Free Pascal 3.0.0 is a new major release providing support for new
architectures and targets and also many new features and compatibility fixes.

Please also see http://wiki.freepascal.org/User_Changes_3.0.0 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * New processor architecture: MIPS (big and little endian variants)
  * New processor architecture: i8086 (primarily focusing legacy MS-DOS)
  * New &quot;processor&quot; architecture: JVM
  * Revived support for Motorola 68k processors (previously available
    in 1.0.x series)
  * Considerably extended supported range of ARM processor variants
  * New platform: AIX/PowerPC
  * New platform: AIX/PowerPC64
  * New platform: Android/ARM
  * New platform: Android/i386
  * New platform: Android/JVM
  * New platform: Android/MIPSEL
  * New platform: AROS/i386
  * New platform: DragonFly/x86_64
  * New platform: Java/JVM
  * New platform: Linux/MIPS
  * New platform: Linux/MIPSEL
  * New platform: msdos/i8086

Compiler:
  * New support for codepage-aware strings (bringing improved compatibility
    to recent Delphi versions)
  * Support for processor sub-architectures (mostly for ARM variants)
  * Support for multiple memory models (i8086 - including memory models
    not supported with the last TP/BP compilers)

RTL:
  * Partial support for codepage-aware strings and Unicode in the RTL
    including transparent character set conversion
  * OS/2 RTL finally provides full support for UnicodeString handling
    when running under OS/2 versions including such support (OS/2 Warp 4
    and up)
  * Direct support for certain OS/2 API functions only available in later
    OS/2 versions while allowing the created binaries to run also on older
    versions

Packages:
  * Big improvements of fpmake (fpmkunit) - all packages and utilities
    (actually everything except the compiler and RTL) are now built using
    fpmake which somewhat decreases dependency on external utilities.
  * New packages rtl-* containing units previously included in RTL; this
    allowed streamlining the RTL and thus speeding up RTL building.
  * New package fpwidestring - native implementation of Unicode string
    handling routines. This allows full support of UnicodeString also
    on targets not supporting Unicode natively or possibly on targets
    requiring linking to libc for such support.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.4
******************************************************************************

Free Pascal 2.6.4 is a point release from the 2.6.0 fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_2.6.4 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:

Packages:
  * Lots and lots fixes and improvements for fcl-db
  * Web and json packages synchronized.
  * Improvements to the chmcmd compiler.
  * Several fixes for winunits (and winceunits)

Platforms:


See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.2
******************************************************************************

Free Pascal 2.6.2 is a point release from the 2.6.0 fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_2.6.2 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:
  * Improvements and fixes for the ARM architecture

Packages:
  * New package fpindexer (indexing engine)
  * Support for observer pattern added to fcl-base (and base classes in RTL)
  * Lots and lots fixes and improvements for fcl-db
        * Support for JSON dataset added among others
  * Fixes and improvements for fcl-passrc (and fpdoc)
  * Updates for PTCPas and gtk2
  * Fpmkunit improvements (better support for future switch to fpmake)
  * Several fixes for x11
  * Several fixes for winunits (and winceunits)

Platforms:
  * Improvements to the NativeNT target (newly introduced as alpha in 2.6.0)
  * Many fixes for OpenBSD and NetBSD (considered in beta state now)
  * Internal ELF writer supported for more BSD targets
  * Fixes and improvements for gba and nds

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.0
******************************************************************************

Free Pascal 2.6.0 is a new major version of the Free Pascal compiler.

Please also see http://wiki.freepascal.org/User_Changes_2.6.0 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * iPhoneSimulator target

Compiler:
  * Many new language features:
     * Objective-Pascal dialect, supported on all Mac OS X and iOS targets
     * constref parameter modifier for &quot;const by reference&quot;
     * Pascal boolean types with multiple sizes (boolean16/32/64)
     * ISO 7185 language mode (except for I/O). Features amongst others:
        * nested procedure variables
        * non-local goto&#039;s
     * Mac Pascal mode improvements
        * nested procedure variables
        * univ modifier
     * Intrinsics
        * sar (shift arithmetic right)
        * bsf/bsr (bitscan forward/reverse)
     * Delphi compatibility mode improvements
        * Nested types, class variables and class local constants
        * Advanced records syntax (no constructors yet)
        * (for..in) Enumerators in records
        * Class and record helpers
        * Generic records, arrays and procedural types
        * Delphi-compatibility of generics improved
        * Scoped enumerations
        * Custom messages for &quot;deprecated&quot; directive
        * Ability to use &quot;&amp;&quot; for escaping keywords
  * New ARM code generator features
     * ARM VFPv2 and VFPv3 floating point unit support
     * Thumb-2 support

Packages:
  * Many improvements to the rtl
  * Many improvements to the database units (fcl-db)
  * Objective-Pascal interfaces to Foundation, AppKit, CoreData and WebCore
  * OpenGL headers updated to OpenGL 4.0
  
Details about these new features can be found at
http://wiki.freepascal.org/FPC_New_Features_2.6.0

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs that have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.4.4
******************************************************************************

Free Pascal 2.4.4 contains most library fixes from early June 2010 till March
2011. There are also some compiler fixes, mostly relating to 64-bit.

Please also see http://wiki.freepascal.org/User_Changes_2.4.4 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Packages:
  * Many improvements to the XML units
  * Many improvements to the database units. 
        * Specially sqlite got quite some fixes.
  * Many improvements to the chm units. 
        * Including a commandline CHM compiler 
  * Many improvements to fppkg and fpmake for another round of testing.

Platforms:
  * Fixes for multi-threading support in OS/2 RTL.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.4.2
******************************************************************************

Free Pascal 2.4.2 contains many fixes and a few new features. Most bugfixes
in the RTL and packages before June 2010 have been merged.

Please also see http://wiki.freepascal.org/User_Changes_2.4.2 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:
  * Support D2006+ FOR..IN, with some FPC specific enhancements. Refer to
     http://wiki.freepascal.org/for-in_loop for more information
  * Support for sealed and abstract classes.

Packages:
  * The existing Mac OS X Universal Interfaces units have been synchronised
    with the Mac OS X 10.6 SDK. Several new units have also been added, and
    where indicated in the Mac OS X 10.6 SDK they have also been enabled for
    iPhoneOS/iOS.
  * Many improvements to the XML units
  * Many improvements to the database units
  * Many improvemnets to the chm units

Platforms:
  * Long term bug in OS/2 implementation of unit Video finally fixed which
    among others allows inclusion of the text-mode IDE (without debugger)
    for this platform as part of the distribution again.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.4.0
******************************************************************************

Free Pascal 2.4.0 contains many fixes and new features. While we did not
manage to incorporate all planned additions, we believe this release offers a
nice collection of new functionality and bug fixes.


Please also see http://wiki.freepascal.org/User_Changes_2.4.0 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * New platform: Mac OS X/PowerPC64
  * New platform: Mac OS X/x86_64
  * New platform: Mac OS X/ARM (iPhone)

Compiler:
  * Support for Delphi-style resource handling
  * Whole-program optimization infrastructure, which initially supports
    program devirtualization and unused virtual method removal
  * Much faster compilation of units containing many type-sections
  * The ability to suppress individual hints/warnings/notes
  * Several improvements to the DWARF debug information generation
  * Fixes to the generics support
  * Fixes to the interface delegation (implements) support
  * Improved cpu register allocation
  * Improved ARM/EABI support
  
RTL:
  * Linearly scaling multi-threaded memory manager
  * Support for (advisory) file locking on Unix-based platforms
    when using the SysUtils file creation/opening routines
  * Support for ANSI ISO Extended Pascal ReadStr/WriteStr
  * A UnicodeString type that, while not yet equivalent to Delphi 2009&#039;s
    UnicodeString type, offers reference counted UnicodeString support on
    the Windows, Linux, Mac OS X, FreeBSD and Beos/Haiku platforms.

Packages:
  * Many improvements to the XML units
  * Many improvements to the database units
  * Updated the common Mac OS X Pascal interfaces to r241, including
    an updated header translation of the CFNetwork framework
  * The zipper unit now works correctly on big endian platforms

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.4
******************************************************************************

Free Pascal 2.2.4 contains many bug fixes and some new features. The 
main purpose of this release is to fix problems reported with FPC 2.2.2.

Please also see http://wiki.freepascal.org/User_Changes_2.2.4 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

All:
  * Experimental packages-installation tool

Packages:
  * Added support for TIFF reading/writing in fcl-image
  * Improvements and fixes in CHM support
  * Fixed linking the gtk2-package with gtk versions above 2.13.4

IDE:
  * Added support for CHM help files

Documentation

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.2
******************************************************************************

Free Pascal 2.2.2 contains many bug fixes and some new features. The 
main purpose of this release is to fix problems reported with FPC 2.2.0,
and to remove all potentially tainted code from our source code base.

Please also see http://wiki.freepascal.org/User_Changes_2.2.2 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

All:
  *  All code potentially infringing on CodeGear copyrighted code has been
     reimplemented using a cleanroom approach.

Platforms:
  * Incompatibilities with Mac OS X 10.5&#039;s new default linker have been
    resolved.

Compiler:
  * PIC support for Mac OS X (on by default, disable with -Cg-)
  * several bugs in the experimental generics support have been fixed,
    but this feature is still in beta
  * initialisation and finalisation of shared libraries has been fixed
    for all Darwin platforms, and for Linux/i386
  * support for {$packset x} directive to enable set packing
    (use {$packset 1} for Delphi-compatible sets, but note that the
     format is different on little and big endian platforms)

RTL:
  * thread resource leaking under unix has been fixed
  * the widestring manager for unix has been completed
  * several floating point to string conversion errors have been fixed
  * significantly improved variant support
  * implementation of RTL exception handler for OS/2 allowing proper
    translation of some runtime errors
  * various fixes for GO32v2 improving useability of this target
  * OS/2 RTL enhanced to allow seamless working with large files (64-bit
    file system API calls) where available (WSeB/MCP/eCS/Warp 4 with FP15)

Packages:
  * the Windows API interface units have been significantly updated
  * Apple universal interfaces updated to r234 of the common FPC/GPC/MW
    interfaces
  * New TRegexEngine class to parse regular expressions

Documentation
  *  Documentation was updated completely to conform to the actual
     state of the compiler and RTL.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.0
******************************************************************************

Free Pascal 2.2.0 contains a lot of bug fixes and new features. The work on
Free Pascal 2.2.0 started halfway during the year 2005. A lot has been improved
since then.

Please also see http://wiki.freepascal.org/User_Changes_2.2.0 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Platforms:
  * New platform: Win64. FPC is the first open source compiler for 64-bit
     Windows operating systems.
  * New processor architecture: 64-bit PowerPC
    * PowerPC/64 support for Linux
  * Mac OS X on Intel (i386) is now supported
  * New platform: Windows CE (Windows Mobile)
  * New platform: Nintendo Game Boy Advance
  * New platform: Nintendo DS
  * Native support for ARM-platform
  * GO32V2 DOS platform got a long needed update

Compiler:
  * Internal linker for win32, win64 and wince, resulting in smaller
    executables, less memory used during compilation, and faster compile
    times for programs using large frameworks like for example the Lazarus
    Component Library.
  * Generics (experimental)
  * Bit packed arrays and records
  * Resourcestrings can now be smartlinked, resulting in smaller executables
  * Multiple resource files support
  * pointer[low..high] syntax to pass C-style pointer arrays to procedures
    using open arrays
  * Interface delegation
  * Proper safecall implementation
  * Wide strings are COM/OLE compatible on Windows
  * Added several speed optimisations, for example:
    * Compiler can omit stack frames (x86 and ARM)
    * Compiler can store records in registers
    * Tail recursion expansion
    * Register renaming optimizations
  * Improved optimizer for ARM CPU
  * Compiler can initialise local variables, function results, and &quot;out&quot;
    parameters with several values (command line parameters -gt till -gtttt)
    to help find uses of uninitialised variables
  * Compiler can now properly deal with paths &gt; 255 characters in all cases
  * Dwarf debug format support
  * Reduced memory usage during compilation
  * Lot of small bugs and compatibility fixes

RTL:
  * Heap uses less memory
  * Improved variants support
  * Improved currency support
  * Exception handling can be used without SysUtils unit
  * Lot of small bug and compatibility fixes

FCL:
  * Improved database support
  * The obsolete sqlitedataset, interbase, fpodbc, ddg, mysqldb3 and mysqldb4
    units are removed
  * Lot of small bugs and compatibility fixes

Packages:
  * Added a new fppkg package manager
  * Improved database support
  * Added Delphi compatible RichEdit unit
  * Apple universal interfaces updated to r204 of the common FPC/GPC/MW
    interfaces
  * Lot of small bugs and compatibility fixes

Free Vision:
  * Now uses resourcestrings

IDE:
  * Evaluate window
  * Improved HTML rendering
  * Improved xterm support
  * Small bug fixes

Misc:
  * Improved documentation
  * Better cross compilation support

For a detailed list of reported bugs that are fixed in this release see the
bugtracker report at http://www.freepascal.org/mantis/changelog_page.php


******************************************************************************
                              What&#039;s New in 2.0.4
******************************************************************************

More than 1000 changes have been made to 2.0.4 since 2.0.2. As this is a bug
fix release, most are fixes for some issues, but new features and performance
enhancements have been added as well.

Compiler:
  * Lot of small bugs and compatibility fixes
  * Updated several translations
  * Improved code generation
  * Improved and fixed PIC code generation
  * Improved register allocation
  * Improved ansistring string code generation
  * Several alignment values increased so the requirements of modern processors
    are met better
  * WINDOWS defined on all windows platforms (Win32, Win64, WinCE)
  * Parameter order for methods with structured results changed
    (result pointer&lt;-&gt;self swapped), please check such methods if they are
    implemented in assembler
  * i386 compiler no longer needs environment variables set when installed on
    an x86_64 Linux distribution

RTL:
  * Lot of small bug and compatibility fixes
  * 64 bit file pointer support on most targets
  * Faster integer to string conversion
  * Endian conversion routines added
  * Improved heap manager
  * Improved ansistring routines
  * PowerPC: Power3/4/5/PPC970 compatibility

FCL:
  * Lot of small bugs and compatibility fixes
  * Improved database support
  * The interbase, fpodbc, ddg, mysqldb3 and mysqldb4 units
    are obsolete and replaced by the sqldb components
  * Oracle support added

Packages:
  * Lot of small bugs and compatibility fixes
  * Improved database support
  * Apple universal interfaces added

Free Vision:
  * New outline unit
  * Small bug fixes
  * Unix: much improved video and keyboard handling
  * Unix: Free Vision applications no longer need to link to libc
  * Linux: grab_vcsa utility to ensure vcsa access

IDE:
  * Small bug fixes
  * Redesigned directories window
  * Reorganised compiler options window
  * Option to use Ctrl+X,C,V for cut/copy/paste

Misc:
  * Improved documentation
  * Better cross compilation support

******************************************************************************
                              What&#039;s New in 2.0.2
******************************************************************************
This is a bug fix release, so don&#039;t expect a big new feature list here. Most
of the almost 700 changes made to 2.0.2 since 2.0.0 are fixes for some issues.

Compiler:
  * Lot of small bugs and compatibility fixes
  * Improved SSE support
  * Improved inlining
  * Enhanced variant support
  * Embedded resource support for targets using elf32 executable format
  + Type checking of compile time expressions
  + Mode MacPas: Support for Mac style objects
  + Mode MacPas: Compile time variables can be given on command line

RTL:
  * Lot of small bugs and compatibility fixes
  * Enhanced variant support
  * Embedded resource support for targets using elf32 executable format

FCL:
  * Lot of small bugs and compatibility fixes
  * Improved SqlDB package

Packages:
  * Lot of small bugs and compatibility fixes
  * Improved data base support

IDE:
  * Small bug fixes

Misc:
  * Improved docs
  * Bug fixes for FreeVision

******************************************************************************
                              What&#039;s New in 2.0.0
******************************************************************************
Compiler:
  + properties in objects are now allowed
  + use of cmov when at least -Cppentium2 is supplied (i386+ only)
  + .p is a searched source extension in macpas mode now
  * Improved MacPas mode
  * Improved variant support
  * Updated language files
  * Improved warnings regarding uninitialised variables
  * Lot of small bugs and compatibility fixes

RTL:
  * Several widestring and unicode fixes
  * Heavily improved variant support
  * Improved threading support
  * Improved 64 bit compatibility
  * Lot of small bugs and compatibility fixes

FCL:
  * Improved data base support
  * Lot of small bugs and compatibility fixes

Packages:
  + Jedi windows api is part of the packages now
  + Windows specific units of the rtl have been moved to packages/base/winunits
  + XFree header conversions to X package added
  * Endian and 64 bit fixes
  * Lot of small bugs and compatibility fixes

IDE:
  * Small bug fixes

Misc:
  * Improved docs
  * Bug fixes for FreeVision


******************************************************************************
                      What&#039;s New in 1.9.8 aka 2.0.0-Rc2
******************************************************************************


Compiler:
  + arm-linux cross compiler for i386-linux
  + SysV style syscalls added for MorphOS
  + Exportable macros for mode MacPas
  + Support procvar declaration in parameters for mode MacPas
  + Give warning if code is never executed in while/if statements
  + Directive {$COPERATORS ON} added, synomym for -Sc
  + Check for uninitialzed from and to values in for-loop statement
  + -Fa&lt;unit&gt; option added to load units in a program before the uses statement
    is parsed
  + -vz for output to stderr
  * Better support for unique types
  * AfterConstruction/BeforeDestruction behaviour is now compatible with Delphi
  * Better support for Widestring
  * Removed {$THREADING ON} directive, threading support is always available
  * Improved code generation on Sparc
  * Lot of small bugs and compatibility fixes
  + On target Mac OS, resource files is supported

RTL:
  + arm Linux support
  * Basic threading support moved to the system unit
  * Operator ** moved to math unit; system.power removed
  * Improved variant support
  * Lot of small bugs and compatibility fixes
  + The unit MacOS (api to Mac OS) for target MacOS

FCL:
  + Support for Interbase/Firebird, PostgreSQL and MySQL 4.0 under windows
  * Database drivers are now dynamically loaded
  * The TSQLQuery is now fully editable using cached updates
  * Lot of small bugs and compatibility fixes

Packages:
  + gtk2 interface units
  * 64 bit compatibility fixes
  * Lot of small bugs and compatibility fixes

IDE:
  + vector unit window
  * x86-64 asssembler debugging support improved
  * Sparc asssembler debugging support improved
  * Some bug fixes

Misc:
  + txt output to fpdoc added
  * some fpdoc bugs fixes
  + demo for macos


******************************************************************************
                      What&#039;s New in 1.9.6 aka 2.0.0-Rc1
******************************************************************************

Compiler:
  + x86_64/amd64 (Linux) compiler
  + Sparc (Linux) compiler
  + PowerPC MorphOS support
  + Mac OS (classic) compiler (for MPW)
  + Netware Libc support (-Tnetwlibc)
  + Register variable support (-Or) for all targets
  + MacPas compiler mode (-Mmacpas)
  * Better inlining support
  * For loop variable assignment is not allowed anymore
  * $fpctarget expands to &lt;cpu&gt;-&lt;os&gt; (except for 8.3 limited targets),
    old $target removed
  * Implicit loading of Variants unit
  * Lots of bug fixes

RTL:
  + x86_64/amd64 Linux support
  + Sparc Linux support
  + PowerPC MorphOS support
  + Mac OS (classic) support (except Sysutils and its dependants)
  + Netware Libc support
  + New heap manager that releases memory back to the OS
  + TThread.Synchronize support
  + utf8bidi unit
  + GetHeapStatus added
  + GetProcessID added
  + SysUtils.GetEnvironmentVariableCount and SysUtils.GetEnvironmentString added
  * gpm unit does not need libgpm anymore
  + Further additions for improved Delphi compatibility
  + System.GetProcessID and System.GetThreadID added
  + Dos.GetMsCount added
  + Support for changing console resolution in Video for Win32
  + Support for using high memory (&gt; 512 MB) under OS/2 (where available)
  - Removed MaxAvail, MemAvail, HeapSize due to their unreliability
    (bogus/misleading return values) in multitasking environment with swapping

FCL:
  + RTTIUtils unit added
  + fpcunit test-framework added
  * Lots of dbf and other db fixes

FV:
  * Updated to fvision implementation, first official release

IDE:
  * Lots of improvements and stability fixes
  * Support latest gdb 6.2.x and 6.3.x releases

Docs:
  + Lots of updates
  + Easier to navigate html documentation
  * fpDoc is used to generate all unit documentation

Misc:
  * Makefiles create units in a separate directory units/cpu-os/
  * More cross compilation improvements


******************************************************************************
                      What&#039;s New in 1.9.4 aka 2.0.0-Beta3
******************************************************************************

Compiler:
  + ARM (Linux) compiler
  + PowerPC Darwin (Mac OS X) support
  + reintroduce keyword support
  + added prefetch(const mem) support
  + MacPas compile mode
  + -gv to generate an executable that can be run under Valgrind &gt;= 2.1
  * register allocator fixes and tweaks
  * better support for preprocessor $IF expressions
  * better overloaded operator support
  * Win32 DLL export table fixes
  * stabs (debuginfo) generation cleanups
  * enum names in RTTI are now in their original case
  * record alignment fixes
  * lots of bug fixes

RTL:
  + ARM Linux support
  + Powerpc Darwin support
  + Sysutils.RaiseLastOSError added
  + Sysutils.GetLastOSError added
  + Classes.TOwnedCollection added
  + Sysutils.FileIsReadOnly added
  + support of widestring and currency in the typinfo unit
  * Better support for Libc based RTL (FPC_USE_LIBC)
  * 64bit cleanup for future x86_64 port
  * ExecuteProcess fixes
  * Linux use getdents syscall instead of deprecated readdir
  * bug fixes

FCL:
  + SDF DB backend
  + TGA support in fpImage
  + support of widestring and currency type in stream related classes
  * Lot of fixes to fpImage classes

Misc:
  * better cross development support
  * Documentation updates
  * Testsuite updates to store testrun results in a database
  * Testsuite updates for cross platform testing, with remote rsh/ssh support


******************************************************************************
                      What&#039;s New in 1.9.2 aka 2.0.0-Beta2
******************************************************************************

Compiler:
  + PowerPC compiler
  + sse/sse2 code generation support
  + &quot;global&quot; property support
  * improved inlining support
  * optimizer enabled again
  * uses register calling conventions by default
  * $fputype directive
  + properties of type single can have default values
  + support of $IF DECLARED()
  + support of DQWORD in inline intel assembler code
  * lots of bug fixes

RTL:
  * more improvements for unix runtime library
  * using FPC_USE_LIBC allows to compile an rtl which uses libc instead of
    syscalls
  + System.Initialize
  + Sysutils.ExecuteProcess
  + System.WideStringManager
  + System.PtrInt and System.PtrUInt
  * ipv6 support
  * lots of bug fixes

FCL:
  + sqlite support
  * bug fixes

Misc:
  * improved docs

******************************************************************************
                      What&#039;s New in 1.9.0 aka 2.0.0-Beta1
******************************************************************************

Compiler:
  + dynamic arrays
  + interfaces
  + variants
  + full widestring support
  + default parameters
  + cross name scope overloading
  + support for the PowerPC, Sparc and ARM processor, installation packages
    will follow within the next weeks
  + new and more sophisticated register allocator
  + inlining across units
  + register calling conventions
  + SSE and SSE2 support for inline assembler
  + PIC code generation
  + new language mode: &quot;Mac Pascal&quot;
  + full boolean evaluation is now also available
  + threadvar support, enabled by using {$threading on}
  * support of int64 integer constants
  * improved Delphi compatibility in -Sd mode
  * a lot of bug fixes
  * large parts of the compiler are rewritten to create a more stable,
    portable and maintainable compiler

RTL:
  + multithreading support
  * completely rewritten unix runtime library
  * improved Delphi compatiblity
  * significantly improved speed of exception related code
  * prepared for big endian and 64 Bit CPUs
  * a lot of bug fixes

FCL:
  + tdataset support
  + html generator
  + 64 Bit file handling
  * a lot of bug fixes

Docs:
  * adapted to reflect new language features

IDE:
  * a lot of bug fixes

Misc:
  * improved cross compilation</div></div></div>      </div>

</fieldset>

    </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 3.0.2, source (<span class="date-display-single">17/02/2017</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/3.0.2/i386-os2/os2302.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/3.0.2/i386-os2/os2302.zip</a></div>  </div>  
          
<fieldset class="what039s-new views-fieldset collapsible collapsed" data-module="views_fieldsets">

  <legend>
    <span class="fieldset-legend">What&#039;s new</span>
  </legend>

  <div class="fieldset-wrapper">
          <div class="views-field views-field-field-download-whats-new"><div class="field-content"><div class="preformatted">                            Free Pascal Compiler

                                Version 3.0.2

******************************************************************************
                              What&#039;s New in 3.0.2
******************************************************************************

Free Pascal 3.0.2 is a point release of the 3.0.x fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_3.0.2 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Rtl:
  * TRect, TPoint and similar types are now type compatible between
    Types and Windows unit, and are now advanced records. 

Packages:
  * googleapi and fcl-pdf packages.
  * fcl-db and web packages synchronized 
  * unicode tables updated.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

                            Free Pascal Compiler

                                Version 3.0.0

******************************************************************************
                              What&#039;s New in 3.0.0
******************************************************************************

Free Pascal 3.0.0 is a new major release providing support for new
architectures and targets and also many new features and compatibility fixes.

Please also see http://wiki.freepascal.org/User_Changes_3.0.0 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * New processor architecture: MIPS (big and little endian variants)
  * New processor architecture: i8086 (primarily focusing legacy MS-DOS)
  * New &quot;processor&quot; architecture: JVM
  * Revived support for Motorola 68k processors (previously available
    in 1.0.x series)
  * Considerably extended supported range of ARM processor variants
  * New platform: AIX/PowerPC
  * New platform: AIX/PowerPC64
  * New platform: Android/ARM
  * New platform: Android/i386
  * New platform: Android/JVM
  * New platform: Android/MIPSEL
  * New platform: AROS/i386
  * New platform: DragonFly/x86_64
  * New platform: Java/JVM
  * New platform: Linux/MIPS
  * New platform: Linux/MIPSEL
  * New platform: msdos/i8086

Compiler:
  * New support for codepage-aware strings (bringing improved compatibility
    to recent Delphi versions)
  * Support for processor sub-architectures (mostly for ARM variants)
  * Support for multiple memory models (i8086 - including memory models
    not supported with the last TP/BP compilers)

RTL:
  * Partial support for codepage-aware strings and Unicode in the RTL
    including transparent character set conversion
  * OS/2 RTL finally provides full support for UnicodeString handling
    when running under OS/2 versions including such support (OS/2 Warp 4
    and up)
  * Direct support for certain OS/2 API functions only available in later
    OS/2 versions while allowing the created binaries to run also on older
    versions

Packages:
  * Big improvements of fpmake (fpmkunit) - all packages and utilities
    (actually everything except the compiler and RTL) are now built using
    fpmake which somewhat decreases dependency on external utilities.
  * New packages rtl-* containing units previously included in RTL; this
    allowed streamlining the RTL and thus speeding up RTL building.
  * New package fpwidestring - native implementation of Unicode string
    handling routines. This allows full support of UnicodeString also
    on targets not supporting Unicode natively or possibly on targets
    requiring linking to libc for such support.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.4
******************************************************************************

Free Pascal 2.6.4 is a point release from the 2.6.0 fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_2.6.4 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:

Packages:
  * Lots and lots fixes and improvements for fcl-db
  * Web and json packages synchronized.
  * Improvements to the chmcmd compiler.
  * Several fixes for winunits (and winceunits)

Platforms:


See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.2
******************************************************************************

Free Pascal 2.6.2 is a point release from the 2.6.0 fixes branch.

Please also see http://wiki.freepascal.org/User_Changes_2.6.2 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:
  * Improvements and fixes for the ARM architecture

Packages:
  * New package fpindexer (indexing engine)
  * Support for observer pattern added to fcl-base (and base classes in RTL)
  * Lots and lots fixes and improvements for fcl-db
        * Support for JSON dataset added among others
  * Fixes and improvements for fcl-passrc (and fpdoc)
  * Updates for PTCPas and gtk2
  * Fpmkunit improvements (better support for future switch to fpmake)
  * Several fixes for x11
  * Several fixes for winunits (and winceunits)

Platforms:
  * Improvements to the NativeNT target (newly introduced as alpha in 2.6.0)
  * Many fixes for OpenBSD and NetBSD (considered in beta state now)
  * Internal ELF writer supported for more BSD targets
  * Fixes and improvements for gba and nds

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.6.0
******************************************************************************

Free Pascal 2.6.0 is a new major version of the Free Pascal compiler.

Please also see http://wiki.freepascal.org/User_Changes_2.6.0 for a list
of changes that may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * iPhoneSimulator target

Compiler:
  * Many new language features:
     * Objective-Pascal dialect, supported on all Mac OS X and iOS targets
     * constref parameter modifier for &quot;const by reference&quot;
     * Pascal boolean types with multiple sizes (boolean16/32/64)
     * ISO 7185 language mode (except for I/O). Features amongst others:
        * nested procedure variables
        * non-local goto&#039;s
     * Mac Pascal mode improvements
        * nested procedure variables
        * univ modifier
     * Intrinsics
        * sar (shift arithmetic right)
        * bsf/bsr (bitscan forward/reverse)
     * Delphi compatibility mode improvements
        * Nested types, class variables and class local constants
        * Advanced records syntax (no constructors yet)
        * (for..in) Enumerators in records
        * Class and record helpers
        * Generic records, arrays and procedural types
        * Delphi-compatibility of generics improved
        * Scoped enumerations
        * Custom messages for &quot;deprecated&quot; directive
        * Ability to use &quot;&amp;&quot; for escaping keywords
  * New ARM code generator features
     * ARM VFPv2 and VFPv3 floating point unit support
     * Thumb-2 support

Packages:
  * Many improvements to the rtl
  * Many improvements to the database units (fcl-db)
  * Objective-Pascal interfaces to Foundation, AppKit, CoreData and WebCore
  * OpenGL headers updated to OpenGL 4.0
  
Details about these new features can be found at
http://wiki.freepascal.org/FPC_New_Features_2.6.0

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs that have been fixed in this release.

******************************************************************************
                              What&#039;s New in 2.4.4
******************************************************************************

Free Pascal 2.4.4 contains most library fixes from early June 2010 till March
2011. There are also some compiler fixes, mostly relating to 64-bit.

Please also see http://wiki.freepascal.org/User_Changes_2.4.4 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Packages:
  * Many improvements to the XML units
  * Many improvements to the database units. 
        * Specially sqlite got quite some fixes.
  * Many improvements to the chm units. 
        * Including a commandline CHM compiler 
  * Many improvements to fppkg and fpmake for another round of testing.

Platforms:
  * Fixes for multi-threading support in OS/2 RTL.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.4.2
******************************************************************************

Free Pascal 2.4.2 contains many fixes and a few new features. Most bugfixes
in the RTL and packages before June 2010 have been merged.

Please also see http://wiki.freepascal.org/User_Changes_2.4.2 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Compiler:
  * Support D2006+ FOR..IN, with some FPC specific enhancements. Refer to
     http://wiki.freepascal.org/for-in_loop for more information
  * Support for sealed and abstract classes.

Packages:
  * The existing Mac OS X Universal Interfaces units have been synchronised
    with the Mac OS X 10.6 SDK. Several new units have also been added, and
    where indicated in the Mac OS X 10.6 SDK they have also been enabled for
    iPhoneOS/iOS.
  * Many improvements to the XML units
  * Many improvements to the database units
  * Many improvemnets to the chm units

Platforms:
  * Long term bug in OS/2 implementation of unit Video finally fixed which
    among others allows inclusion of the text-mode IDE (without debugger)
    for this platform as part of the distribution again.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.4.0
******************************************************************************

Free Pascal 2.4.0 contains many fixes and new features. While we did not
manage to incorporate all planned additions, we believe this release offers a
nice collection of new functionality and bug fixes.


Please also see http://wiki.freepascal.org/User_Changes_2.4.0 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

Platforms:
  * New platform: Mac OS X/PowerPC64
  * New platform: Mac OS X/x86_64
  * New platform: Mac OS X/ARM (iPhone)

Compiler:
  * Support for Delphi-style resource handling
  * Whole-program optimization infrastructure, which initially supports
    program devirtualization and unused virtual method removal
  * Much faster compilation of units containing many type-sections
  * The ability to suppress individual hints/warnings/notes
  * Several improvements to the DWARF debug information generation
  * Fixes to the generics support
  * Fixes to the interface delegation (implements) support
  * Improved cpu register allocation
  * Improved ARM/EABI support
  
RTL:
  * Linearly scaling multi-threaded memory manager
  * Support for (advisory) file locking on Unix-based platforms
    when using the SysUtils file creation/opening routines
  * Support for ANSI ISO Extended Pascal ReadStr/WriteStr
  * A UnicodeString type that, while not yet equivalent to Delphi 2009&#039;s
    UnicodeString type, offers reference counted UnicodeString support on
    the Windows, Linux, Mac OS X, FreeBSD and Beos/Haiku platforms.

Packages:
  * Many improvements to the XML units
  * Many improvements to the database units
  * Updated the common Mac OS X Pascal interfaces to r241, including
    an updated header translation of the CFNetwork framework
  * The zipper unit now works correctly on big endian platforms

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.4
******************************************************************************

Free Pascal 2.2.4 contains many bug fixes and some new features. The 
main purpose of this release is to fix problems reported with FPC 2.2.2.

Please also see http://wiki.freepascal.org/User_Changes_2.2.4 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

All:
  * Experimental packages-installation tool

Packages:
  * Added support for TIFF reading/writing in fcl-image
  * Improvements and fixes in CHM support
  * Fixed linking the gtk2-package with gtk versions above 2.13.4

IDE:
  * Added support for CHM help files

Documentation

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.2
******************************************************************************

Free Pascal 2.2.2 contains many bug fixes and some new features. The 
main purpose of this release is to fix problems reported with FPC 2.2.0,
and to remove all potentially tainted code from our source code base.

Please also see http://wiki.freepascal.org/User_Changes_2.2.2 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Some highlights are:

All:
  *  All code potentially infringing on CodeGear copyrighted code has been
     reimplemented using a cleanroom approach.

Platforms:
  * Incompatibilities with Mac OS X 10.5&#039;s new default linker have been
    resolved.

Compiler:
  * PIC support for Mac OS X (on by default, disable with -Cg-)
  * several bugs in the experimental generics support have been fixed,
    but this feature is still in beta
  * initialisation and finalisation of shared libraries has been fixed
    for all Darwin platforms, and for Linux/i386
  * support for {$packset x} directive to enable set packing
    (use {$packset 1} for Delphi-compatible sets, but note that the
     format is different on little and big endian platforms)

RTL:
  * thread resource leaking under unix has been fixed
  * the widestring manager for unix has been completed
  * several floating point to string conversion errors have been fixed
  * significantly improved variant support
  * implementation of RTL exception handler for OS/2 allowing proper
    translation of some runtime errors
  * various fixes for GO32v2 improving useability of this target
  * OS/2 RTL enhanced to allow seamless working with large files (64-bit
    file system API calls) where available (WSeB/MCP/eCS/Warp 4 with FP15)

Packages:
  * the Windows API interface units have been significantly updated
  * Apple universal interfaces updated to r234 of the common FPC/GPC/MW
    interfaces
  * New TRegexEngine class to parse regular expressions

Documentation
  *  Documentation was updated completely to conform to the actual
     state of the compiler and RTL.

See http://bugs.freepascal.org/changelog_page.php for the list of reported
bugs which have been fixed in this release.


******************************************************************************
                              What&#039;s New in 2.2.0
******************************************************************************

Free Pascal 2.2.0 contains a lot of bug fixes and new features. The work on
Free Pascal 2.2.0 started halfway during the year 2005. A lot has been improved
since then.

Please also see http://wiki.freepascal.org/User_Changes_2.2.0 for a list
of changes which may affect the behaviour of previously working code, and
how to cope with these changes.

Platforms:
  * New platform: Win64. FPC is the first open source compiler for 64-bit
     Windows operating systems.
  * New processor architecture: 64-bit PowerPC
    * PowerPC/64 support for Linux
  * Mac OS X on Intel (i386) is now supported
  * New platform: Windows CE (Windows Mobile)
  * New platform: Nintendo Game Boy Advance
  * New platform: Nintendo DS
  * Native support for ARM-platform
  * GO32V2 DOS platform got a long needed update

Compiler:
  * Internal linker for win32, win64 and wince, resulting in smaller
    executables, less memory used during compilation, and faster compile
    times for programs using large frameworks like for example the Lazarus
    Component Library.
  * Generics (experimental)
  * Bit packed arrays and records
  * Resourcestrings can now be smartlinked, resulting in smaller executables
  * Multiple resource files support
  * pointer[low..high] syntax to pass C-style pointer arrays to procedures
    using open arrays
  * Interface delegation
  * Proper safecall implementation
  * Wide strings are COM/OLE compatible on Windows
  * Added several speed optimisations, for example:
    * Compiler can omit stack frames (x86 and ARM)
    * Compiler can store records in registers
    * Tail recursion expansion
    * Register renaming optimizations
  * Improved optimizer for ARM CPU
  * Compiler can initialise local variables, function results, and &quot;out&quot;
    parameters with several values (command line parameters -gt till -gtttt)
    to help find uses of uninitialised variables
  * Compiler can now properly deal with paths &gt; 255 characters in all cases
  * Dwarf debug format support
  * Reduced memory usage during compilation
  * Lot of small bugs and compatibility fixes

RTL:
  * Heap uses less memory
  * Improved variants support
  * Improved currency support
  * Exception handling can be used without SysUtils unit
  * Lot of small bug and compatibility fixes

FCL:
  * Improved database support
  * The obsolete sqlitedataset, interbase, fpodbc, ddg, mysqldb3 and mysqldb4
    units are removed
  * Lot of small bugs and compatibility fixes

Packages:
  * Added a new fppkg package manager
  * Improved database support
  * Added Delphi compatible RichEdit unit
  * Apple universal interfaces updated to r204 of the common FPC/GPC/MW
    interfaces
  * Lot of small bugs and compatibility fixes

Free Vision:
  * Now uses resourcestrings

IDE:
  * Evaluate window
  * Improved HTML rendering
  * Improved xterm support
  * Small bug fixes

Misc:
  * Improved documentation
  * Better cross compilation support

For a detailed list of reported bugs that are fixed in this release see the
bugtracker report at http://www.freepascal.org/mantis/changelog_page.php


******************************************************************************
                              What&#039;s New in 2.0.4
******************************************************************************

More than 1000 changes have been made to 2.0.4 since 2.0.2. As this is a bug
fix release, most are fixes for some issues, but new features and performance
enhancements have been added as well.

Compiler:
  * Lot of small bugs and compatibility fixes
  * Updated several translations
  * Improved code generation
  * Improved and fixed PIC code generation
  * Improved register allocation
  * Improved ansistring string code generation
  * Several alignment values increased so the requirements of modern processors
    are met better
  * WINDOWS defined on all windows platforms (Win32, Win64, WinCE)
  * Parameter order for methods with structured results changed
    (result pointer&lt;-&gt;self swapped), please check such methods if they are
    implemented in assembler
  * i386 compiler no longer needs environment variables set when installed on
    an x86_64 Linux distribution

RTL:
  * Lot of small bug and compatibility fixes
  * 64 bit file pointer support on most targets
  * Faster integer to string conversion
  * Endian conversion routines added
  * Improved heap manager
  * Improved ansistring routines
  * PowerPC: Power3/4/5/PPC970 compatibility

FCL:
  * Lot of small bugs and compatibility fixes
  * Improved database support
  * The interbase, fpodbc, ddg, mysqldb3 and mysqldb4 units
    are obsolete and replaced by the sqldb components
  * Oracle support added

Packages:
  * Lot of small bugs and compatibility fixes
  * Improved database support
  * Apple universal interfaces added

Free Vision:
  * New outline unit
  * Small bug fixes
  * Unix: much improved video and keyboard handling
  * Unix: Free Vision applications no longer need to link to libc
  * Linux: grab_vcsa utility to ensure vcsa access

IDE:
  * Small bug fixes
  * Redesigned directories window
  * Reorganised compiler options window
  * Option to use Ctrl+X,C,V for cut/copy/paste

Misc:
  * Improved documentation
  * Better cross compilation support

******************************************************************************
                              What&#039;s New in 2.0.2
******************************************************************************
This is a bug fix release, so don&#039;t expect a big new feature list here. Most
of the almost 700 changes made to 2.0.2 since 2.0.0 are fixes for some issues.

Compiler:
  * Lot of small bugs and compatibility fixes
  * Improved SSE support
  * Improved inlining
  * Enhanced variant support
  * Embedded resource support for targets using elf32 executable format
  + Type checking of compile time expressions
  + Mode MacPas: Support for Mac style objects
  + Mode MacPas: Compile time variables can be given on command line

RTL:
  * Lot of small bugs and compatibility fixes
  * Enhanced variant support
  * Embedded resource support for targets using elf32 executable format

FCL:
  * Lot of small bugs and compatibility fixes
  * Improved SqlDB package

Packages:
  * Lot of small bugs and compatibility fixes
  * Improved data base support

IDE:
  * Small bug fixes

Misc:
  * Improved docs
  * Bug fixes for FreeVision

******************************************************************************
                              What&#039;s New in 2.0.0
******************************************************************************
Compiler:
  + properties in objects are now allowed
  + use of cmov when at least -Cppentium2 is supplied (i386+ only)
  + .p is a searched source extension in macpas mode now
  * Improved MacPas mode
  * Improved variant support
  * Updated language files
  * Improved warnings regarding uninitialised variables
  * Lot of small bugs and compatibility fixes

RTL:
  * Several widestring and unicode fixes
  * Heavily improved variant support
  * Improved threading support
  * Improved 64 bit compatibility
  * Lot of small bugs and compatibility fixes

FCL:
  * Improved data base support
  * Lot of small bugs and compatibility fixes

Packages:
  + Jedi windows api is part of the packages now
  + Windows specific units of the rtl have been moved to packages/base/winunits
  + XFree header conversions to X package added
  * Endian and 64 bit fixes
  * Lot of small bugs and compatibility fixes

IDE:
  * Small bug fixes

Misc:
  * Improved docs
  * Bug fixes for FreeVision


******************************************************************************
                      What&#039;s New in 1.9.8 aka 2.0.0-Rc2
******************************************************************************


Compiler:
  + arm-linux cross compiler for i386-linux
  + SysV style syscalls added for MorphOS
  + Exportable macros for mode MacPas
  + Support procvar declaration in parameters for mode MacPas
  + Give warning if code is never executed in while/if statements
  + Directive {$COPERATORS ON} added, synomym for -Sc
  + Check for uninitialzed from and to values in for-loop statement
  + -Fa&lt;unit&gt; option added to load units in a program before the uses statement
    is parsed
  + -vz for output to stderr
  * Better support for unique types
  * AfterConstruction/BeforeDestruction behaviour is now compatible with Delphi
  * Better support for Widestring
  * Removed {$THREADING ON} directive, threading support is always available
  * Improved code generation on Sparc
  * Lot of small bugs and compatibility fixes
  + On target Mac OS, resource files is supported

RTL:
  + arm Linux support
  * Basic threading support moved to the system unit
  * Operator ** moved to math unit; system.power removed
  * Improved variant support
  * Lot of small bugs and compatibility fixes
  + The unit MacOS (api to Mac OS) for target MacOS

FCL:
  + Support for Interbase/Firebird, PostgreSQL and MySQL 4.0 under windows
  * Database drivers are now dynamically loaded
  * The TSQLQuery is now fully editable using cached updates
  * Lot of small bugs and compatibility fixes

Packages:
  + gtk2 interface units
  * 64 bit compatibility fixes
  * Lot of small bugs and compatibility fixes

IDE:
  + vector unit window
  * x86-64 asssembler debugging support improved
  * Sparc asssembler debugging support improved
  * Some bug fixes

Misc:
  + txt output to fpdoc added
  * some fpdoc bugs fixes
  + demo for macos


******************************************************************************
                      What&#039;s New in 1.9.6 aka 2.0.0-Rc1
******************************************************************************

Compiler:
  + x86_64/amd64 (Linux) compiler
  + Sparc (Linux) compiler
  + PowerPC MorphOS support
  + Mac OS (classic) compiler (for MPW)
  + Netware Libc support (-Tnetwlibc)
  + Register variable support (-Or) for all targets
  + MacPas compiler mode (-Mmacpas)
  * Better inlining support
  * For loop variable assignment is not allowed anymore
  * $fpctarget expands to &lt;cpu&gt;-&lt;os&gt; (except for 8.3 limited targets),
    old $target removed
  * Implicit loading of Variants unit
  * Lots of bug fixes

RTL:
  + x86_64/amd64 Linux support
  + Sparc Linux support
  + PowerPC MorphOS support
  + Mac OS (classic) support (except Sysutils and its dependants)
  + Netware Libc support
  + New heap manager that releases memory back to the OS
  + TThread.Synchronize support
  + utf8bidi unit
  + GetHeapStatus added
  + GetProcessID added
  + SysUtils.GetEnvironmentVariableCount and SysUtils.GetEnvironmentString added
  * gpm unit does not need libgpm anymore
  + Further additions for improved Delphi compatibility
  + System.GetProcessID and System.GetThreadID added
  + Dos.GetMsCount added
  + Support for changing console resolution in Video for Win32
  + Support for using high memory (&gt; 512 MB) under OS/2 (where available)
  - Removed MaxAvail, MemAvail, HeapSize due to their unreliability
    (bogus/misleading return values) in multitasking environment with swapping

FCL:
  + RTTIUtils unit added
  + fpcunit test-framework added
  * Lots of dbf and other db fixes

FV:
  * Updated to fvision implementation, first official release

IDE:
  * Lots of improvements and stability fixes
  * Support latest gdb 6.2.x and 6.3.x releases

Docs:
  + Lots of updates
  + Easier to navigate html documentation
  * fpDoc is used to generate all unit documentation

Misc:
  * Makefiles create units in a separate directory units/cpu-os/
  * More cross compilation improvements


******************************************************************************
                      What&#039;s New in 1.9.4 aka 2.0.0-Beta3
******************************************************************************

Compiler:
  + ARM (Linux) compiler
  + PowerPC Darwin (Mac OS X) support
  + reintroduce keyword support
  + added prefetch(const mem) support
  + MacPas compile mode
  + -gv to generate an executable that can be run under Valgrind &gt;= 2.1
  * register allocator fixes and tweaks
  * better support for preprocessor $IF expressions
  * better overloaded operator support
  * Win32 DLL export table fixes
  * stabs (debuginfo) generation cleanups
  * enum names in RTTI are now in their original case
  * record alignment fixes
  * lots of bug fixes

RTL:
  + ARM Linux support
  + Powerpc Darwin support
  + Sysutils.RaiseLastOSError added
  + Sysutils.GetLastOSError added
  + Classes.TOwnedCollection added
  + Sysutils.FileIsReadOnly added
  + support of widestring and currency in the typinfo unit
  * Better support for Libc based RTL (FPC_USE_LIBC)
  * 64bit cleanup for future x86_64 port
  * ExecuteProcess fixes
  * Linux use getdents syscall instead of deprecated readdir
  * bug fixes

FCL:
  + SDF DB backend
  + TGA support in fpImage
  + support of widestring and currency type in stream related classes
  * Lot of fixes to fpImage classes

Misc:
  * better cross development support
  * Documentation updates
  * Testsuite updates to store testrun results in a database
  * Testsuite updates for cross platform testing, with remote rsh/ssh support


******************************************************************************
                      What&#039;s New in 1.9.2 aka 2.0.0-Beta2
******************************************************************************

Compiler:
  + PowerPC compiler
  + sse/sse2 code generation support
  + &quot;global&quot; property support
  * improved inlining support
  * optimizer enabled again
  * uses register calling conventions by default
  * $fputype directive
  + properties of type single can have default values
  + support of $IF DECLARED()
  + support of DQWORD in inline intel assembler code
  * lots of bug fixes

RTL:
  * more improvements for unix runtime library
  * using FPC_USE_LIBC allows to compile an rtl which uses libc instead of
    syscalls
  + System.Initialize
  + Sysutils.ExecuteProcess
  + System.WideStringManager
  + System.PtrInt and System.PtrUInt
  * ipv6 support
  * lots of bug fixes

FCL:
  + sqlite support
  * bug fixes

Misc:
  * improved docs

******************************************************************************
                      What&#039;s New in 1.9.0 aka 2.0.0-Beta1
******************************************************************************

Compiler:
  + dynamic arrays
  + interfaces
  + variants
  + full widestring support
  + default parameters
  + cross name scope overloading
  + support for the PowerPC, Sparc and ARM processor, installation packages
    will follow within the next weeks
  + new and more sophisticated register allocator
  + inlining across units
  + register calling conventions
  + SSE and SSE2 support for inline assembler
  + PIC code generation
  + new language mode: &quot;Mac Pascal&quot;
  + full boolean evaluation is now also available
  + threadvar support, enabled by using {$threading on}
  * support of int64 integer constants
  * improved Delphi compatibility in -Sd mode
  * a lot of bug fixes
  * large parts of the compiler are rewritten to create a more stable,
    portable and maintainable compiler

RTL:
  + multithreading support
  * completely rewritten unix runtime library
  * improved Delphi compatiblity
  * significantly improved speed of exception related code
  * prepared for big endian and 64 Bit CPUs
  * a lot of bug fixes

FCL:
  + tdataset support
  + html generator
  + 64 Bit file handling
  * a lot of bug fixes

Docs:
  * adapted to reflect new language features

IDE:
  * a lot of bug fixes

Misc:
  * improved cross compilation</div></div></div>      </div>

</fieldset>

    </div>
  <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 3.0.0 (<span class="date-display-single">21/11/2015</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/i386-os2/os2300full.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/i386-os2/os2300full.zip</a></div>  </div>  
              </div>
  <div class="views-row views-row-5 views-row-odd">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 3.0.0, docs (<span class="date-display-single">21/11/2015</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/docs/doc-pdf.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/docs/doc-pdf.zip</a></div>  </div>  
              </div>
  <div class="views-row views-row-6 views-row-even">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 3.0.0, source (<span class="date-display-single">17/11/2015</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/i386-os2/os2300.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/i386-os2/os2300.zip</a></div>  </div>  
              </div>
  <div class="views-row views-row-7 views-row-odd">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 2.6.4 (<span class="date-display-single">03/03/2014</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/2.6.4/i386-os2/os2264full.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/2.6.4/i386-os2/os2264full.zip</a></div>  </div>  
              </div>
  <div class="views-row views-row-8 views-row-even">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 2.6.4, docs (<span class="date-display-single">03/03/2014</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/2.6.4/docs/doc-pdf.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/2.6.4/docs/doc-pdf.zip</a></div>  </div>  
              </div>
  <div class="views-row views-row-9 views-row-odd views-row-last">
      
  <div class="views-field views-field-field-download-version views-accordion-header">        <div class="field-content"><b>Ver. 2.6.4, source (<span class="date-display-single">03/03/2014</span>)</b></div>  </div>  
  <div class="views-field views-field-field-download-lnk">        <div class="field-content"><a href="ftp://ftp.freepascal.org/pub/fpc/dist/2.6.4/i386-os2/os2264.zip" class="ext"><img src="/sites/ecsoft2.org/files/downloadx16.png" />&nbsp;ftp://ftp.freepascal.org/pub/fpc/dist/2.6.4/i386-os2/os2264.zip</a></div>  </div>  
              </div>
    </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-record-page view-id-record_page view-display-id-attachment_1">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>
</div>
<div id="block-views-record-page-last-updated-block" class="block block-views">

    
  <div class="content">
    <div class="view view-record-page-last-updated view-id-record_page_last_updated view-display-id-block view-dom-id-6d4432a77a6b9c3b903a053e6ca47558">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-changed">        <span class="field-content"><i>Last updated: Thu, 23/02/2017 - 06:20</i></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>  </div>
</div>
<div id="block-gtranslate-gtranslate" class="block block-gtranslate">

    <h2>GTranslate</h2>
  
  <div class="content">
    <script type="text/javascript">
/* <![CDATA[ */
eval(unescape("eval%28function%28p%2Ca%2Cc%2Ck%2Ce%2Cr%29%7Be%3Dfunction%28c%29%7Breturn%28c%3Ca%3F%27%27%3Ae%28parseInt%28c/a%29%29%29+%28%28c%3Dc%25a%29%3E35%3FString.fromCharCode%28c+29%29%3Ac.toString%2836%29%29%7D%3Bif%28%21%27%27.replace%28/%5E/%2CString%29%29%7Bwhile%28c--%29r%5Be%28c%29%5D%3Dk%5Bc%5D%7C%7Ce%28c%29%3Bk%3D%5Bfunction%28e%29%7Breturn%20r%5Be%5D%7D%5D%3Be%3Dfunction%28%29%7Breturn%27%5C%5Cw+%27%7D%3Bc%3D1%7D%3Bwhile%28c--%29if%28k%5Bc%5D%29p%3Dp.replace%28new%20RegExp%28%27%5C%5Cb%27+e%28c%29+%27%5C%5Cb%27%2C%27g%27%29%2Ck%5Bc%5D%29%3Breturn%20p%7D%28%276%207%28a%2Cb%29%7Bn%7B4%282.9%29%7B3%20c%3D2.9%28%22o%22%29%3Bc.p%28b%2Cf%2Cf%29%3Ba.q%28c%29%7Dg%7B3%20c%3D2.r%28%29%3Ba.s%28%5C%27t%5C%27+b%2Cc%29%7D%7Du%28e%29%7B%7D%7D6%20h%28a%29%7B4%28a.8%29a%3Da.8%3B4%28a%3D%3D%5C%27%5C%27%29v%3B3%20b%3Da.w%28%5C%27%7C%5C%27%29%5B1%5D%3B3%20c%3B3%20d%3D2.x%28%5C%27y%5C%27%29%3Bz%283%20i%3D0%3Bi%3Cd.5%3Bi++%294%28d%5Bi%5D.A%3D%3D%5C%27B-C-D%5C%27%29c%3Dd%5Bi%5D%3B4%282.j%28%5C%27k%5C%27%29%3D%3DE%7C%7C2.j%28%5C%27k%5C%27%29.l.5%3D%3D0%7C%7Cc.5%3D%3D0%7C%7Cc.l.5%3D%3D0%29%7BF%286%28%29%7Bh%28a%29%7D%2CG%29%7Dg%7Bc.8%3Db%3B7%28c%2C%5C%27m%5C%27%29%3B7%28c%2C%5C%27m%5C%27%29%7D%7D%27%2C43%2C43%2C%27%7C%7Cdocument%7Cvar%7Cif%7Clength%7Cfunction%7CGTranslateFireEvent%7Cvalue%7CcreateEvent%7C%7C%7C%7C%7C%7Ctrue%7Celse%7CdoGTranslate%7C%7CgetElementById%7Cgoogle_translate_element2%7CinnerHTML%7Cchange%7Ctry%7CHTMLEvents%7CinitEvent%7CdispatchEvent%7CcreateEventObject%7CfireEvent%7Con%7Ccatch%7Creturn%7Csplit%7CgetElementsByTagName%7Cselect%7Cfor%7CclassName%7Cgoog%7Cte%7Ccombo%7Cnull%7CsetTimeout%7C500%27.split%28%27%7C%27%29%2C0%2C%7B%7D%29%29"))
/* ]]> */
</script><style type="text/css">
<!--
#goog-gt-tt {display:none !important;}

.goog-te-banner-frame {display:none !important;}

.goog-te-menu-value:hover {text-decoration:none !important;}

body {top:0 !important;}

#google_translate_element2 {display:none!important;}
-->
</style><div id="google_translate_element2"></div>
<script type="text/javascript">function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en', autoDisplay: false}, 'google_translate_element2');}</script>
<script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script><style type="text/css">
<!--
a.gtflag {background-image:url('/sites/all/modules/gtranslate/gtranslate-files/16a.png');}
a.gtflag:hover {background-image:url('/sites/all/modules/gtranslate/gtranslate-files/16.png');}
-->
</style><a href="javascript:doGTranslate('en|en')" title="English" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-0px -0px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="English" /></a> <a href="javascript:doGTranslate('en|nl')" title="Dutch" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-0px -100px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="Dutch" /></a> <a href="javascript:doGTranslate('en|fr')" title="French" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-200px -100px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="French" /></a> <a href="javascript:doGTranslate('en|de')" title="German" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-300px -100px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="German" /></a> <a href="javascript:doGTranslate('en|ko')" title="Korean" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-0px -200px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="Korean" /></a> <a href="javascript:doGTranslate('en|ru')" title="Russian" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-500px -200px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="Russian" /></a> <a href="javascript:doGTranslate('en|sv')" title="Swedish" class="gtflag" style="font-size:16px;padding:1px 0;background-repeat:no-repeat;background-position:-700px -200px;"><img src="/sites/all/modules/gtranslate/gtranslate-files/blank.png" height="16" width="16" style="border:0;vertical-align:top;" alt="Swedish" /></a> <select onchange="doGTranslate(this);"><option value="">Select Language</option><option value="en|en" style="font-weight:bold;background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -0px;padding-left:18px;">English</option><option value="en|af" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -688px;padding-left:18px;">Afrikaans</option><option value="en|sq" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -560px;padding-left:18px;">Albanian</option><option value="en|ar" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -16px;padding-left:18px;">Arabic</option><option value="en|hy" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -832px;padding-left:18px;">Armenian</option><option value="en|az" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -848px;padding-left:18px;">Azerbaijani</option><option value="en|eu" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -864px;padding-left:18px;">Basque</option><option value="en|be" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -768px;padding-left:18px;">Belarusian</option><option value="en|bg" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -32px;padding-left:18px;">Bulgarian</option><option value="en|ca" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -384px;padding-left:18px;">Catalan</option><option value="en|hr" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -80px;padding-left:18px;">Croatian</option><option value="en|cs" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -96px;padding-left:18px;">Czech</option><option value="en|da" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -112px;padding-left:18px;">Danish</option><option value="en|nl" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -128px;padding-left:18px;">Dutch</option><option value="en|et" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -576px;padding-left:18px;">Estonian</option><option value="en|tl" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -400px;padding-left:18px;">Filipino</option><option value="en|fi" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -144px;padding-left:18px;">Finnish</option><option value="en|fr" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -160px;padding-left:18px;">French</option><option value="en|gl" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -592px;padding-left:18px;">Galician</option><option value="en|ka" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -880px;padding-left:18px;">Georgian</option><option value="en|de" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -176px;padding-left:18px;">German</option><option value="en|el" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -192px;padding-left:18px;">Greek</option><option value="en|ht" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -896px;padding-left:18px;">Haitian Creole</option><option value="en|iw" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -416px;padding-left:18px;">Hebrew</option><option value="en|hi" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -208px;padding-left:18px;">Hindi</option><option value="en|hu" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -608px;padding-left:18px;">Hungarian</option><option value="en|is" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -784px;padding-left:18px;">Icelandic</option><option value="en|id" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -432px;padding-left:18px;">Indonesian</option><option value="en|ga" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -736px;padding-left:18px;">Irish</option><option value="en|ja" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -240px;padding-left:18px;">Japanese</option><option value="en|ko" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -256px;padding-left:18px;">Korean</option><option value="en|lv" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -448px;padding-left:18px;">Latvian</option><option value="en|lt" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -464px;padding-left:18px;">Lithuanian</option><option value="en|mk" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -800px;padding-left:18px;">Macedonian</option><option value="en|ms" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -704px;padding-left:18px;">Malay</option><option value="en|mt" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -624px;padding-left:18px;">Maltese</option><option value="en|no" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -272px;padding-left:18px;">Norwegian</option><option value="en|fa" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -672px;padding-left:18px;">Persian</option><option value="en|pl" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -288px;padding-left:18px;">Polish</option><option value="en|pt" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -304px;padding-left:18px;">Portuguese</option><option value="en|ro" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -320px;padding-left:18px;">Romanian</option><option value="en|ru" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -336px;padding-left:18px;">Russian</option><option value="en|sr" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -480px;padding-left:18px;">Serbian</option><option value="en|sk" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -496px;padding-left:18px;">Slovak</option><option value="en|sl" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -512px;padding-left:18px;">Slovenian</option><option value="en|es" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -352px;padding-left:18px;">Spanish</option><option value="en|sw" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -720px;padding-left:18px;">Swahili</option><option value="en|sv" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -368px;padding-left:18px;">Swedish</option><option value="en|th" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -640px;padding-left:18px;">Thai</option><option value="en|tr" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -656px;padding-left:18px;">Turkish</option><option value="en|uk" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -528px;padding-left:18px;">Ukrainian</option><option value="en|ur" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -912px;padding-left:18px;">Urdu</option><option value="en|vi" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -544px;padding-left:18px;">Vietnamese</option><option value="en|cy" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -752px;padding-left:18px;">Welsh</option><option value="en|yi" style="background:url('/sites/all/modules/gtranslate/gtranslate-files/16l.png') no-repeat scroll 0 -816px;padding-left:18px;">Yiddish</option></select>  </div>
</div>
<div id="block-commentsblock-comment-form-block" class="block block-commentsblock">

    
  <div class="content">
    <div id="comments" class="comment-wrapper">
  
  
      <h2 class="title comment-form">Add new comment</h2>
    <form class="comment-form" action="/comment/reply/246" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name </label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text" />
</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div></div><input type="hidden" name="form_build_id" value="form-ckmsSbB4_16ik1Zi3orhu2TjYZSwJYHsCI5IJ0aqg78" />
<input type="hidden" name="form_id" value="comment_node_record_form" />
<input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="" />
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="description mollom-privacy">By submitting this form, you accept the <a href="https://www.mollom.com/web-service-privacy-policy" class="mollom-target" rel="nofollow">Mollom privacy policy</a>.</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /><input type="submit" id="edit-preview" name="op" value="Preview" class="form-submit" /></div></div></form>  </div>
  </div>
</div>
<div id="block-block-5" class="block block-block">

    
  <div class="content">
    <p><a href="http://creativecommons.org/licenses/by/4.0/" rel="license"><img style="border-width: 0;" src="https://i.creativecommons.org/l/by/4.0/88x31.png" alt="Creative Commons License" /></a><br />This work is licensed under a <a href="http://creativecommons.org/licenses/by/4.0/" rel="license">Creative Commons Attribution 4.0 International License</a>.</p>
  </div>
</div>
  </div>
      
    </div></div> <!-- /.section, /#content -->

    
  </div></div> <!-- /#main, /#main-wrapper -->

  
  <div id="footer-wrapper"><div class="section">

          <div id="footer-columns" class="clearfix">
                  <div class="region region-footer-secondcolumn">
    <div id="block-block-2" class="block block-block">

    
  <div class="content">
    <p><a href="contact">Contact us!</a></p>
  </div>
</div>
  </div>
          <div class="region region-footer-thirdcolumn">
    <div id="block-block-9" class="block block-block">

    
  <div class="content">
    <p>   </p>
  </div>
</div>
  </div>
          <div class="region region-footer-fourthcolumn">
    <div id="block-views-rotating-text-block" class="block block-views">

    
  <div class="content">
    <div class="view view-rotating-text view-id-rotating_text view-display-id-block view-dom-id-dffa329daaaf41badc0ccbc4bd4f0675">
        
  
  
      <div class="view-content">
      
  <div class="skin-default">
    
    <div id="views_slideshow_cycle_main_rotating_text-block" class="views_slideshow_cycle_main views_slideshow_main"><div id="views_slideshow_cycle_teaser_section_rotating_text-block" class="views-slideshow-cycle-main-frame views_slideshow_cycle_teaser_section">
  <div id="views_slideshow_cycle_div_rotating_text-block_0" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-1 views-row-odd">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-0 views-row-odd views-row-first">
    
  <div class="views-field views-field-title-field-et">        <div class="field-content"><p><a href="http://www.ecomstation.com/" target="_blank">eComStation.com portal</a></p></div>  </div></div>
</div>
<div id="views_slideshow_cycle_div_rotating_text-block_1" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-2 views_slideshow_cycle_hidden views-row-even">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-1 views-row-even">
    
  <div class="views-field views-field-title-field-et">        <div class="field-content"><p><a href="http://arcanoae.com/" target="_blank">Arca Noae portal</a></p></div>  </div></div>
</div>
<div id="views_slideshow_cycle_div_rotating_text-block_2" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-3 views_slideshow_cycle_hidden views-row-odd">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-2 views-row-odd">
    
  <div class="views-field views-field-title-field-et">        <div class="field-content"><p><a href="http://os2ports.smedley.id.au/" target="_blank">Paul Smedley&#039;s Unix Ports for OS/2 &amp; eCS</a></p></div>  </div></div>
</div>
<div id="views_slideshow_cycle_div_rotating_text-block_3" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-4 views_slideshow_cycle_hidden views-row-even">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-3 views-row-even">
    
  <div class="views-field views-field-title-field-et">        <div class="field-content"><p><a href="http://ecomstation.it/" target="_blank">eComStation.it, consulting and IT services</a></p></div>  </div></div>
</div>
<div id="views_slideshow_cycle_div_rotating_text-block_4" class="views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-5 views_slideshow_cycle_hidden views-row-odd">
  <div class="views-slideshow-cycle-main-frame-row-item views-row views-row-4 views-row-odd views-row-last">
    
  <div class="views-field views-field-title-field-et">        <div class="field-content"><p><a href="http://en.ecomstation.ru/" target="_blank">eComStation.RU, applications, news, reviews, hardware</a></p></div>  </div></div>
</div>
</div>
</div>
      </div>
    </div>
  
  
  
  
  
  
</div>  </div>
</div>
  </div>
      </div> <!-- /#footer-columns -->
    
    
  </div></div> <!-- /.section, /#footer-wrapper -->

</div></div> <!-- /#page, /#page-wrapper -->
  <script type="text/javascript" src="http://www.ecsoft2.org/sites/ecsoft2.org/files/js/js__5K3cP299UfyXPVyDSjB-m4UKJ8bZGgzCpqT9AHwiO8.js"></script>
</body>
</html>
